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AutoTRAX PCB Design Express (DEX), is a fully integrated electronic schematic capture program combined with an easy to use PCB Designer.

It has all the features you expect and need to rapidly and easily take your design from conception through to production. Its in-built hierarchical project manager lets you perform both top-down and bottom-up design and reuse design components and sub-systems.

Starting with its easy to use Schematic Capture mode, you can drag previously created parts onto your design sheets and rapidly and reliably connected the terminals together using wires, buses and off-page connectors. AutoTRAX DEX ensures that your design remains correct throughout with no ‘dangling wires’ or design rule violations.

You can also create your own parts either in-place on your design sheets or using the integrated Part Creator. Again, design integrity is maintained throughout using the AutoTRAX DEX design rule checker.

When you are satisfied with your design, you can then quickly proceed to produce your PCB board without leaving AutoTRAX DEX. 

AutoTRAX DEX will take your hierarchical design and place the components, with or without your assistance. Next AutoTRAX DEX can either auto-route your board or you can use a combination of automatic and manual routing to quickly and reliably complete all electrical wiring. The design of AutoTRAX DEX's internal data ensures full electrical integrity between your schematic and PCB designs; there are no surprises with lost or missing PCB tracks or wires, or those ‘extra’ wires.

Now that you have your design finished and routed you can then produce all Computer Aided Manufacturing files you will need to produce the board, drill the holes, cut its profile, order parts using the Bill Of Materials, and place your parts using the pick and place files. These files can be place together and forwarded to your favourite board manufacturers, electronically via email.

In only a short time you will see the fruits of your labour and will be pleased at the time and money you have saved.

Find out more...
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Microsoft Windows and 4K Monitors





Microsoft Windows has long supported 4K resolution, and this is certainly true as of the latest versions of Windows as of my knowledge cutoff in September 2021.

To utilize 4K resolution on a monitor, you need:

•A 4K Monitor: This is a monitor that supports a resolution of 3840 x 2160 pixels, which is considered Ultra High Definition (UHD). Some monitors even support 4096 x 2160 pixels, which is the standard for 4K in digital cinema.

•A Graphics Card that Supports 4K: Your computer's graphics card needs to be able to output at a 4K resolution. As 4K has become more standard, this is a common feature on most modern graphics cards. Make sure to verify that your graphics card can support this resolution.

•Appropriate Cables: You'll need an HDMI (version 1.4 or higher), DisplayPort (version 1.2 or higher), or USB-C cable that supports 4K resolution. The specific cable will depend on what ports are available on your monitor and graphics card.

•4K Content: Having a 4K monitor won't do you much good if you don't have content that is rendered in 4K. This includes games, videos, photos, etc.

•Software Support: Your operating system and software should support 4K as well. As of my knowledge cutoff in 2021, the latest versions of Windows do support 4K.

Setting your Windows PC to use 4K resolution is usually as simple as going into your display settings (right-click on the desktop, then select "Display settings") and then choosing the 4K resolution from the drop-down menu.

However, be aware that not all software and websites are optimized for 4K, and may appear small or blurry on a high-resolution display. Some apps or websites might not scale properly, leading to smaller text or images. Windows does offer some built-in tools for scaling up the size of text and other items on the screen to compensate for the increased resolution. You can adjust these settings in the same "Display settings" menu.

Moreover, running your PC at a higher resolution can demand more from your computer's graphics card, which might result in increased heat or noise from your computer's fans. This isn't usually a problem with modern hardware, but it's something to keep in mind.

By 2023, most of these issues have likely been ironed out, as 4K has become more common. However, without specific information about the state of technology in 2023, I can't provide a more precise answer.

HDMI Cables

An HDMI (High Definition Multimedia Interface) cable is a type of digital connection used to transmit high-quality video and audio signals. These cables are widely used in home theater systems, gaming consoles, and many other consumer electronics because they can handle high-definition (HD) video and multichannel audio over a single cable.

Here are a few more details about HDMI cables:

•Quality: HDMI cables are designed to handle video resolutions of 1080p and beyond, including advanced display technologies such as 4K and 3D.

•Audio: They can transmit multi-channel audio data, supporting all standard and high-definition consumer electronics video formats and up to 8 channels of digital audio.

•Variants: As of my knowledge cut-off in September 2021, HDMI cables come in different versions, like HDMI 1.4, 2.0, 2.1 etc., each with increased capabilities. HDMI 2.1, for example, supports up to 10K resolution and dynamic HDR.

•CEC feature: HDMI also includes a feature called CEC (Consumer Electronics Control) that allows the user to command and control up to 15 CEC-enabled devices.

•ARC and eARC: HDMI cables also have features called ARC (Audio Return Channel) and eARC (enhanced Audio Return Channel) which simplify the process of sending audio from a television to a home theater system or soundbar.

•Ethernet: Some HDMI cables have an Ethernet channel that enables high-speed, bi-directional communication. This means devices connected by the HDMI cable can share an internet connection.

It's also important to note that the HDMI interface is backward compatible with the single-link Digital Visual Interface (DVI) used on many older devices, so with the right adapter, you can still use an HDMI cable with a device that only has a DVI output.

DisplayPort Cables

DisplayPort is a digital display interface primarily used to connect a video source (like a computer or gaming console) to a display device, such as a computer monitor or a television. Like HDMI, DisplayPort can also carry audio, USB, and other forms of data.

Here are some key aspects of DisplayPort cables:

•Resolution and Refresh Rates: As of my last training cut-off in September 2021, DisplayPort 1.4 can support resolutions up to 8K (7680 × 4320) at 60Hz, or 4K (3840 x 2160) at 240Hz, making it a suitable option for high-resolution displays and demanding games.

•Multi-Stream Transport (MST): This feature of DisplayPort allows you to use multiple monitors through a single DisplayPort connection by "daisy-chaining" them together, a feature not generally supported by HDMI.

•Adaptive Sync: DisplayPort supports adaptive sync technology (like AMD's FreeSync and NVIDIA's G-Sync), which matches the display refresh rate to the frame rate of the graphics card. This reduces issues like screen tearing in games.

•Different Connectors: DisplayPort connectors come in two sizes, standard (often just called DisplayPort) and DisplayPort Mini (or Mini DisplayPort). The Mini DisplayPort was commonly used on older Apple devices but has largely been replaced by USB-C or Thunderbolt.

•Backward Compatibility: DisplayPort is backward compatible with VGA, DVI, and HDMI, but you'll need the appropriate adapter.

It's also important to note that while HDMI and DisplayPort may look similar at first glance, they were developed by different industry consortiums for slightly different market segments (consumer electronics vs. personal computer), and they differ in terms of sound and video specifications, supported technologies, and physical connectors.

USB-C Video Cables

USB-C, also known as USB Type-C, is a type of USB (Universal Serial Bus) connector that's reversible, meaning you can plug it in either way. USB-C cables and ports are becoming increasingly common on various types of devices, including laptops, smartphones, and tablets.

Apart from data transfer and charging, USB-C can also support video output if the device supports a protocol called USB-C Alt Mode. This feature repurposes some of the wires in a USB-C 3.1 cable for direct device-to-host transmission of alternate data protocols. The four high-speed lanes, coupled with supporting power and data code, enable this cable to carry significantly more data.

Here are some key aspects of USB-C video cables:

•DisplayPort Over USB-C: This is a version of Alt Mode. If a device supports DisplayPort Alt Mode, a USB-C to DisplayPort cable (or a USB-C to USB-C cable if both devices have USB-C ports) can carry a DisplayPort signal.

•HDMI Over USB-C: Similarly, HDMI Alt Mode for USB-C allows HDMI-enabled source devices to utilize a USB-C cable to directly connect to HDMI-enabled displays.

•Thunderbolt 3 and 4: Some USB-C ports also support Thunderbolt 3 or 4, which are standards that allow for very high data transfer rates and video output capabilities. A single Thunderbolt 3 port and cable can transmit DisplayPort and HDMI video signals, data for external storage drives, and power for device charging.

•Power Delivery: USB-C also supports USB Power Delivery (USB PD), a fast charging standard that can deliver up to 100W of power. This means you could potentially use the same USB-C cable to charge your laptop, output video to a monitor, and transfer files to an external drive.

•Dongles and Adapters: Since USB-C is compatible with so many different protocols, you can use dongles and adapters to connect to a wide variety of devices. For instance, if your laptop has a USB-C port but your monitor has an HDMI port, you can use a USB-C to HDMI dongle to connect the two.

Please note that not all USB-C ports, cables, or devices support all these features. The exact capabilities can vary depending on the specific device and how its manufacturer has chosen to implement the USB-C standard. Always check your device's specifications to see what is supported.
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Where are the AutoTRAX DEX files?





AutoTRAX DEX is installed in the following directories:

Roaming Data Files

C:\Users\XXXX\AppData\Roaming\AutoTRAX DEX Software\AutoTRAX DEX

Machine Specific Files

C:\Users\XXXX\AppData\Local\AutoTRAX DEX Software\AutoTRAX DEX

The Parts Library

The default location of the parts library is:

C:\Users\XXXX\AppData\Roaming\AutoTRAX DEX Software\AutoTRAX DEX\Library

Where XXXX is your account name.

The Windows Registry

The Windows Registry is a hierarchical database that stores configuration settings and options on Microsoft Windows operating systems. It contains settings for low-level operating system components and for applications running on the platform that have opted to use the registry. The kernel, device drivers, services, SAM, user interface and third party applications can all make use of the registry. The registry also provides a means to access counters for profiling system performance.

AutoTRAX DEX does not use the registry or set entries in the Registry.

Configuration files are in C:\Users\XXXX\AppData\Roaming\AutoTRAX DEX Software\AutoTRAX DEX\Settings
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Authorizing Your Copy





When you purchase AutoTRAX DEX you will receive a signon id and password. This will allow you to automatically authorize your copy of AutoTRAX DEX on the machine you are using.

Demo Expired

When you start AutoTRAX DEX and it has not been authorized, if the demo period has expired you will see the following dialog.

[image: clip0094]


Getting you Software Key Automatically

Click [image: clip0096] to get your key online. You will then see the following dialog. Enter you Sign in ID and your password to authorize AutoTRAX DEX on your machine. This will automatically retrieve the Software Key from the AutoTRAX DEX web site. You do NOT need the software key; AutoTRAX DEX sends it automatically to the website to get your key. All you need is you Sign In ID and your password. You will have been sent this automatically when you purchased AutoTRAX DEX. Check your email. If you can't find it, try your spam folder.

[image: clip0018]


Sometimes your Firewall may prevent AutoTRAX DEX from contacting the AutoTRAX DEX  web site, in this case you will have to enter the software key manually.

You can enter the software key manually. To get a software key you can go to https://pcbdex.com/Account/SoftwareKey

Demo Not Expired

If the demo period of your copy of AutoTRAX DEX has not expired you can authorize your copy click the  [image: clip0017] button in the Home→Account menu.  

If you do not have a valid license you will see the sign on dialog box below. If you have purchased a software license you will have received a sign in id and password by email. If you do not have it please check your spam box. If you still cannot find it then please contact us via email using this link. If you have not purchased a license the click on the purchase button [image: clip0019]to obtain a license

If you cannot sign on and you know you have a valid license, your firewall may be block access for AutoTRAX DEX to the internet.  Click to find out how to configure your firewall.

[image: clip0018]


Click here for more details about your account.
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Authorizing Your Copy Machine Without Internet Acccess





To check your software license or enter a software key click the Software License button [image: clip0017] in the Home→Account menu. 

[image: clip1000]


If you have a valid license the account details dialog shown below will be displayed.

[image: clip0997]


If it does not have a valid license then you will see the dialog box below. 

When you start AutoTRAX DEX and it has not been authorized, if the demo period has expired you will see the dialog box below. 

[image: clip0999]


 

Enter the Software key or click [image: clip2801]
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About AutoTRAX PCB Design Express (DEX)





In keeping with the Open Design philosophy of AutoTRAX DEX the following details on the development of AutoTRAX DEX are provided.

Source Code ( 7 August, 2023)

DEX source code (not including 3rd party code)

940,986 lines of code (6,558,169 words) in 3915 files which is equivalent to 23,524 pages.

Help Manual  (7 August, 2023)

This help manual has: 

•1215 topics.

•250,186 words. 

•23,879 paragraphs.

•3113 images.

•164 videos.

Development

C#

 

[image: clip0032]   [image: clip0034]   

 AutoTRAX DEX is mainly written in C# .NET 4 and will run on Windows Vista, Windows 7 and Windows 8., Windows 10 Windows 11. 

C# (pronounced "C sharp") is a modern, general-purpose programming language developed by Microsoft as part of its .NET platform. C# was designed by Anders Hejlsberg and his team and was first released in 2000. It's syntactically similar to Java and C++, and it's particularly well-suited for building Windows desktop applications and games, but it's also used to develop web and mobile applications.

Key features and characteristics of C# include:

Object-Oriented: C# is fundamentally an object-oriented language, meaning it supports the concepts of encapsulation, inheritance, and polymorphism.

Type-Safe: The C# language is type-safe. It checks the type of an object at compile-time and doesn't allow type conversions that are unsafe.

Automatic Garbage Collection: In C#, you don't need to explicitly allocate and deallocate memory—this is managed automatically by the garbage collector.

Interoperability: C# has good interoperability, which means it can process and use code libraries that were written in other languages.

Versatility: C# can be used to create a wide variety of applications, including Windows client applications, Windows Store apps, backend systems, cloud-based services, enterprise software, and even video games (using the Unity game engine).

Modern Features: C# has many modern language features, such as indexers, delegates, events, and LINQ (Language Integrated Query), that make it a powerful and flexible language for all kinds of software development.

Part of the .NET Framework: Being a part of the .NET framework, C# comes with a large standard library that supports a variety of common programming tasks, such as string manipulation, data collection, database connectivity, and more.

 

[image: apple]It will also run on Apple Macs.

 

Microsoft CLI

When AutoTRAX DEX is installed it is compiled on the target machine for the target processor. AutoTRAX DEX is therefore a 64 bit application on a 64 bit O/S and a 32 bit application on a 32 bit O/S. The code is also optimized for the target processor version. This is impossible to do in C++ applications. There is only one installer executable.

The Common Language Infrastructure (CLI) is a specification developed by Microsoft that describes the executable code and runtime environment for running applications written in a variety of high-level programming languages. It's a key part of Microsoft's .NET platform.

The CLI includes a bytecode language, known as Common Intermediate Language (CIL, but sometimes also referred to as MSIL, for Microsoft Intermediate Language). When you compile .NET code (from any .NET language, like C#, VB.NET, F# etc.), it is compiled into this CIL.

The Just-In-Time (JIT) compiler is a part of the CLI and it's responsible for converting the CIL code into machine code that can be executed by the processor in the computer running the application. This compilation happens at runtime (i.e., "just in time" for execution) which is where the term "Just-In-Time Compilation" comes from.

Here's how the process typically works:

1.You write code in a high-level .NET language, such as C#.

2.When you compile your code, the .NET compiler converts it into CIL code. This is a form of bytecode — it's lower-level than C# code, but it's not yet machine code.

3.When you run the program, the .NET runtime loads your CIL code.

4.Just before each piece of code is executed, the JIT compiler in the .NET runtime converts the CIL code into machine code.

5.The machine code is then executed.

One of the advantages of JIT compilation is that, because the final compilation happens on the end user's machine, the compiler knows the exact configuration of the machine and can optimize the machine code for that specific environment.

.NET also supports Ahead-of-Time (AOT) compilation, in which CIL code is converted into machine code in advance, before the application is run. This can provide performance benefits and is commonly used in scenarios such as iOS development where JIT compilation is not allowed. However, JIT remains a core part of the .NET platform. AutoTRAX uses converts to CIL code into machine code on installation.

nGen

Ngen.exe, which stands for Native Image Generator, is a tool that creates native images from managed code assemblies and installs them into the native image cache on the local computer. The runtime can use native images from the cache instead of using the just-in-time (JIT) compiler to compile the original assembly.

Here's why AutoTRAX uses Ngen.exe:

Performance: Applications can load faster because they're pre-compiled to native code, reducing the work done by the JIT compiler during application startup.

Shared Code: If you have assemblies that are shared between applications, using Ngen can improve performance because the native images can also be shared, so each application doesn't need to have its own JIT-compiled code.

Security: Because the assemblies are precompiled, there's less opportunity for malicious code to inject itself at runtime.

 

However, using Ngen.exe does have some disadvantages:

Disk Space: Native images are often larger than the original assemblies, so they consume more disk space.

Versioning: If you update an assembly, you have to regenerate the native image.

Initial Compilation: There is an overhead to compile the assemblies to native code in the first place.

Ngen.exe is used by the AutoTRAX installer.

 

Winforms

For the User Interface, AutoTRAX uses WinForms.

Windows Forms (WinForms) is a Graphical User Interface (GUI) class library included in Microsoft's .NET Framework. Developers use it to create Windows desktop applications. It's one of the .NET Framework's two main GUI libraries, the other being Windows Presentation Foundation (WPF).

WinForms was introduced with the .NET Framework in 2002 and has been widely used for desktop applications in the Windows environment. It provides a set of classes for creating windows, controls, and components. These classes include everything from basic elements, such as buttons, checkboxes, and text boxes, to more complex elements like dialog boxes, menus, and toolbars.

 

3D and Open GL

[image: clip0031]

 AutoTRAX uses OpenGL for 3D.

OpenGL, which stands for Open Graphics Library, is a cross-language, cross-platform application programming interface (API) for rendering 2D and 3D vector graphics. The API is typically used to interact with a Graphics Processing Unit (GPU), to achieve hardware-accelerated rendering.

Since OpenGL is a low-level, high-performance library, it can create high-quality graphics in real-time, which makes it particularly useful in the field of computer games, simulations, and modeling applications. It provides functions to draw geometric primitives (like points, lines, and polygons), transformations of graphical objects, texture mapping, and many others.

OpenGL is platform-independent and served as the foundation for several other APIs and libraries, like WebGL (for web applications) and OpenGL ES (a simplified version for mobile and embedded systems).

 

Previous Versions

The previous version of AutoTRAX DEX was AutoTRAX DEX EDA. This was written in C++ and MFC. 

MFC stands for Microsoft Foundation Class Library. It is a collection of classes (coded in C++), provided by Microsoft to make it easier to develop desktop applications for the Windows operating system. Essentially, MFC provides an Object-Oriented interface to the Windows API, which is normally programmed in C.

[image: clip0035]

A version of AutoTRAX DEX was developed using C++ and QT but this was abandoned in favor of .NET.

Both AutoTRAX DEX and AutoTRAX DEX EDA have been used, under license, to develop application for other software companies. 

Qt (often pronounced as "cute") is a free and open-source widget toolkit for creating graphical user interfaces as well as cross-platform applications that run on various software and hardware platforms such as Linux, Windows, macOS, Android or embedded systems with little or no change in the underlying codebase while still being a native application with native capabilities and speed.

Qt was first developed by Trolltech, a Norwegian software company. Nokia later acquired Trolltech, and then the Qt project was distributed under the terms of the GNU Lesser General Public License (LGPL), among others.

 

Website

[image: clip0030] 

The AutoTRAX DEX website was written in C# with ASP.NET MVC 5. It is an HTML 5 site and uses SQLServer, WebGL,  SVG and JavaScript with j Query.

ASP.NET MVC 5 is a framework for building scalable, standards-based web applications using well-established design patterns and the power of ASP.NET and the .NET Framework.

 

Visual Studio

[image: clip0029] 

AutoTRAX DEX is developed with Visual Studio Ultimate. Design methodology is Scrum Agile.

Microsoft Visual Studio is an integrated development environment (IDE) from Microsoft. It is used to develop computer programs, as well as websites, web apps, web services, and mobile apps. Visual Studio uses Microsoft software development platforms such as Windows API, Windows Forms, Windows Presentation Foundation, Windows Store, and Microsoft Silverlight.

Key Features of Microsoft Visual Studio include:

Code Editor: The code editor supports syntax highlighting and code completion using IntelliSense for not only variables, functions, and methods but also language constructs like loops and queries.

Debugger: Visual Studio includes a debugger that works both as a source-level debugger and as a machine-level debugger. It works with both managed code and native code and can be used for debugging applications written in any language supported by Visual Studio.

Designer: Visual Studio includes a host of visual designers to aid in the development of applications. These include form designers for building UI, web designer for building web pages and applications, class designer for visualizing and editing the structure of classes, and many others.

Integrated Tools: Visual Studio comes integrated with many tools to aid in software development. These include a form designer for building GUI applications, web designer, class designer, and database schema designer, among others.

Support for multiple languages: Visual Studio supports multiple programming languages by allowing the code editor and debugger to support (to varying degrees) nearly any programming language, provided a language-specific service exists.

Extensions: Visual Studio also supports the creation and use of plug-ins, which enhance the functionality of the IDE or provide integrations with other software or services. This makes Visual Studio a highly extensible platform.

 

SqLite

[image: clip1589]

AutoTRAX DEX uses SQLite. SQLite is a C-language library that implements a small, fast, self-contained, high-reliability, full-featured, SQL database engine. SQLite is the most used database engine in the world. SQLite is built into all mobile phones and most computers and comes bundled inside countless other applications that people use every day.

SQLite is a software library that provides a relational database management system (RDBMS). The distinguishing feature of SQLite is that it's embedded: instead of running as a separate process with its own system-level privileges, SQLite works directly with the application that uses it. This makes it extremely lightweight, efficient, and easy to integrate with a wide range of applications.

SQLite provides an interface to a "database" that is a single file on disk. It implements most of SQL standard, including transactions, and it can use indices to speed up queries. However, as a part of its simplicity, it doesn't support some more advanced RDBMS features, such as right outer joins or full outer joins.

Some of the key characteristics of SQLite include:

Serverless: SQLite doesn't run as a server process, which differentiates it from other databases such as MySQL or PostgreSQL. Applications open SQLite files directly, which simplifies setup and administration.

Zero-Configuration: There's no setup or administration needed to start using an SQLite database. This makes it a popular choice for development, testing, and even some production environments.

Transactional: SQLite transactions are fully ACID-compliant, allowing safe access from multiple processes or threads.

Self-Contained: A complete SQLite database is stored in a single cross-platform disk file.

SQLite is used widely both in industry and in academia, for both prototyping and for lightweight applications that don't require the full power of a larger RDBMS or where database needs are modest. As of my knowledge cutoff in September 2021, SQLite is embedded in a wide range of popular software, including most smartphones (both iOS and Android), many web browsers, and countless standalone applications.
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Clearing Sheets and the PCB





To clear all the contents of a schematic or a PCB click the Edit→Edit→[image: clip0193] button.
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Aligning Objects





Aligning graphical objects is a process in graphic design that involves positioning elements in relation to each other or to the overall layout. Good alignment can make a design more organized, balanced, and aesthetically pleasing.

It's important to remember that while these tools are useful, alignment also depends on the designer's judgement. Good alignment is not just about precision, but also about creating a design that is balanced, harmonious, and communicates the intended message effectively.

To align 2 or more objects you must first select them.

[image: clip0218]


Original

Align Top

Click the Layout→Align→[image: clip0222] button.

[image: clip0977]


Align Bottom

Click the Layout→Align→[image: clip0221] button/

[image: clip0219]


Align Left

Click the Layout→Align→[image: clip0223] button.

[image: clip0231]


Align Right

Click the Layout→Align→[image: clip0224] button.

[image: clip0232]


Align Center

Click the  Layout→Align→[image: clip0225] button.

[image: clip0230]


Align Middle

Click the  Layout→Align→[image: clip0226] button.

[image: clip0227]
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Adding Coordinates





To add a coordinate to a sheet click on the [image: clip0108] button in the Add→Dimension button group.

As you move the mouse cursor in the viewport, you will see the position cursor displayed below. You can press the 's' key to turn snap on/off.

[image: clip0110]


Adding a Coordinate

 

When the coordinate is at the position you want to place it, left-click on to finish creating it. 

You can enter the value of the X and Y coordinates by first pressing the Enter key followed by the X coordinate, the Enter key, the Y coordinate and finally the Enter key to complete creating the coordinate.

[image: clip0112]


Entering the X and Y coordinate using the keyboard

[image: clip0111]


Completed Coordinate
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Adding Point Guides





There are 2 ways to add a point guide to a sheet.

1.The first and easiest is to hold down the left mouse button on the ruler origin in the upper left hand corner of the rulers (If rulers are visible) and drag it into position.

2.The second method is to click on the [image: clip0123] button in the Add→Guides button group. 

3.[image: clip0125]


The point guide and its X,Y position during initial creation

In both cases, as you drag the guide to position it you can enter a number value by first pressing the Enter key and then the X and Y coordinate or click the left mouse button to place the guide.

You can press the 's' key at any time to turn snap on or off.
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Angled Guides





Angled guides are angled lines that act as a visual clue and also as an X,Y coordinate snap point when adding or moving objects.

[image: clip0118]


An angled guide (blue diagonal line)
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Adding Angled Guides





Unlike the other guides there is only one way to add an angled guide to a sheet and that is by clicking on the [image: clip0126] button in the Add→Guides button group. 

[image: clip0127]


The angled guide and its crossing point during initial creation

As you drag the guide to position it you can enter a number value by first pressing the Enter key and then the crossing coordinate or click the left mouse button to define the crossing point..

You can press the 's' key at any time to turn snap on or off.

Now as you drag the mouse, the angle of the angled guide will vary. Left-click to finish creating the angled guide or you can enter a number value for the angle in degrees by first pressing the Enter key and then entering the angle.

[image: clip0128]


The angle of the angled guide as you drag the mouse
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Angle Guide Editor





[image: clip2814]


The Angled Guide Editor
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Adding Aligned Dimensions





1.To add an aligned dimension click the [image: clip0177] in the Add→Dimension button group. 

2.Now as you move the mouse in the viewport, you will see the start coordinate. Left-click to define the start point of the dimension or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the starting point.

[image: clip0178]


3.Now as you move the mouse, the dimension will be drawn and the end point shown.

[image: clip0179]


4.Left-click to set the end point or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the end point.

5.Now as you move the mouse you will see the dimension offset from the start and end points as shown below. Left-click again to finally define the dimension or press the Enter key and enter the numeric value of the offset.

[image: clip0181]
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Adding Linear Dimensions





1.To add a linear dimension click the [image: clip0182] in the Add→Dimension button group. 

2.Now as you move the mouse in the viewport, you will see the start coordinate. Left-click to define the start point of the dimension or press the Enter key and enter the numeric value of the start point.

[image: clip0178]


3.Now as you move the mouse the dimension will be drawn and the end point shown.

[image: clip0183]


4.Left-click to set the end point or press the Enter key and enter the numeric value of the end point.

5.Now as you move the mouse you will see the dimension offset from the start and end points as shown below. Depending on the position of the mouse, the dimension will show the horizontal or vertical distance. Left-click again to finally define the dimension or press the Enter key and enter the numeric value of the offset.

[image: clip0185]


Dimension showing the vertical distance

[image: clip0184]


Dimension showing the horizontal distance
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Arcs





In AutoTRAX DEX you can add graphical arcs. In schematics they have no electrical significance. However, in PCBs they have significance  if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.

Arcs have a width that can be zero for an infinitely thin arc. However, if you add arcs to a PCB you need to make sure their width is at least the size of the manufacturing minimum width.

Arcs also have color and can be semi-transparent. It is even possible to define an invisible arc. If you have snap to objects enabled, objects will snap to invisible arcs.

Arcs can also have a line style as shown below.
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Adding Arcs





To add an arc to a graphical sheet, click on the [image: clip0260] button in the Add→Shapes ribbon menu button group.

To set the  Line Styles before adding arcs, use the Default Graphics Settings

Move the mouse inside a graphical sheet's viewport. You will see the arc center cross follow the mouse.

[image: clip0261]


Mouse Center Point

Left-click when the center cross is where you want to start the arc or press the Enter key followed by the X value, Enter/Space/Tab, and then the Y value and Enter/Space/Tab.

You will next be prompted for the start angle of the arc. Moving the mouse defines the arc's diameter and displays the start angle. Left-click to define the start angle of the arc or press the Enter/Space/Tab key followed by the start angle numerical value in degrees.

[image: clip0263]


Arc diameter and start angle

Now move the mouse to define the arc's end point . Finally left-click to define the arc or press the Enter/Space/Tab key followed by the end angle numerical value in degrees.

[image: clip0262]
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Arc Editor





[image: clip2759]


 

[image: clip2760]
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Blocks





Blocks are objects imported from DXF files.
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Adding Curves





You can add open and closed curves.

To set the  Fill Styles and Line Styles before adding curves use the Default Graphics Settings.

[image: An Open Curve]An Open Curve



[image: A Closed Curve]A Closed Curve



To add an open curve to a graphical sheet, click on the [image: clip0512]  button in the Add→Shapes ribbon menu button group.

 

Curves  in AutoTRAX DEX are piecewise bezier curves.

A Bezier curve is a mathematical curve used in computer graphics and related fields to model smooth curves. It is defined by a set of control points, which influence the shape of the curve.

A piecewise Bezier curve is a Bezier curve that is made up of several Bezier curve segments, each defined by its own set of control points. These segments are joined together end-to-end to form a smooth curve.

The advantage of using a piecewise Bezier curve is that it allows for greater flexibility in modeling curves with varying degrees of curvature. By using multiple segments, each with their own control points, it is possible to create a curve that has both sharp corners and smooth curves.

To create a piecewise Bezier curve, one simply needs to define the control points for each segment and then join them together. The resulting curve will be a smooth, continuous curve that can be used for a wide range of applications in computer graphics and related fields.

To add a closed curve to a graphical sheet, click on one of the [image: clip0508]  buttons in the Add→Shapes ribbon menu button group.

[image: clip0509] Adds a hollow curve.

[image: clip0510] Adds a filled curve with border.

[image: clip0511] Adds a filled curve without a border.

Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start a curve or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

[image: Move to the start of the curve]Move to the start of the curve



Now as you mouse the mouse the first segment of the curve will be defined. 

[image: Move to end of first segment]Move to end of first segment



Left-click to define the second point for the curve or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the second point. Now as you move the mouse the curves second segment is being defined.

[image: clip0514]


Open Curve

[image: clip0515]


Closed Curve

 

Continue this to complete the curve. If you are adding an open curve and you place the cursor over the first point of the curve and left-click, the curve will be automatically closed and filled.

Double-click to end the curve with the next segment to be placed or press the ESC key to end the curve with the last completed curve segment. 
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Circle/Ellipse Editor





[image: clip2762]


 

[image: clip2763]
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Adding Ellipses and Circles





You can add ellipses or circles. A circle is an ellipse with the x and y radii being the same.

To set the  Fill Styles and Line Styles before adding ellipses use the Default Graphics Settings

[image: clip0528]


Ellipses/Circles

To add an ellipse to a graphical sheet click on one of the [image: clip0529]  buttons in the Add→Shapes ribbon menu button group.

[image: clip0530] Adds a hollow ellipse.

[image: clip0531] Adds a filled ellipse with border.

[image: clip0532] Adds a filled ellipse without a border.

Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start an ellipse or circle or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

[image: clip0261]


Now as you move the mouse the ellipse will change in size and aspect ratio.

If you hold down the Shift key as you move the mouse, the ellipse will be centered at the first point.

If you hold down the CTRL key as you move the mouse, the ellipse will be circle with width and height the same.

If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the circle will be centered at the first point as you move the mouse, with the width and the height being the same.

Left-click when the ellipse/circle is the shape you want or press the Enter key followed by the numeric values for the width and height of the ellipse.

[image: clip0314]


Dragging the mouse defines the ellipses size
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Adding Images





You can pictures/images to your design.

 

[image: clip0533]


An image with transparency

To add an image to a graphical sheet click on one of the [image: clip0534]  button in the Add→Shapes ribbon menu button group.

An Open Image file dialog will be display.  Use this to select the image file to be inserted and click the Open button.

Move the mouse inside a graphical sheet's viewport. You will see the point cross follow the mouse. Left-click mouse button when the point cross is where you want to start the image or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

[image: clip0261]


Now as you move the mouse the image will change in size and aspect ratio.

If you hold down the Shift key as you move the mouse, the image will be centered at the first point.

If you hold down the CTRL key as you move the mouse, the image will be square with width and height the same.

If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the image will be centered at the first point and will be square with the width and the height the same.

Alternately, you can add an image with a simple click, hold, and drag.  When the point cross is where you want to start the image, left-click and hold the left button. Left-click and hold to re-size the image and release the button; the image will be placed.  In this mode, if you hit Enter before releasing the left button, you will be able to enter exact X and Y numerical values for the width and heights respectively. Note, using the Shift and CTRL keys as described above also works with this alternate method.

 

[image: clip0536]


Dragging the mouse defines the image size
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Adding Lines





In AutoTRAX DEX you can add graphical lines to both schematics and PCBs.

To set the  Line Styles before adding lines, use the Default Graphics Settings

1.To add a line, click on the line button in the Add→Shapes menu.

2.Now move the mouse to where you want to start the line then:

a.Left-click when the start cross is where you want to start of the line to be or 

b.press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

[image: clip0261]


Start point cursor and input boxes

3.Now as you move the mouse you will see the line being drawn and the end point will follow the cursor. If snap is enabled, both the start and the end points will snap to the grid. At any time you can turn snap on and off by pressing the ‘s’ key. As you move the mouse, the length and angle of the line displayed.  Left click to define the line's end point or press the Enter key followed by the length, Enter, the angle, and Enter to exactly define the end point of line. Note that as you move the end of the line, if smart pan is enabled, the viewport will automatically pan so the end point is always visible. If possible, the original view will be restored.

[image: clip0587]


End point cursor and input boxes

To turn smart-pan on or off, click on the smart-pan button on the status bar.

If you have Auto-repeat commands enabled, then you will be prompted to enter the start point for another line. To cancel adding more lines press either the ESC key or right-click  and select cancel from the context menu.

Alternately, you can create a line by left-clicking and holding at the location for the start of the line, moving to the end location for the line and releasing the left button. The line is then added to your design.
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Adding Notes





You can add text notes.

To set the  Fill Styles, Line Styles and Font Style before adding notes use the Default Graphics Settings

[image: clip0552]


Notes and rounded notes

To add a note to a graphical sheet click on one of the [image: clip0548]  buttons in the Add→Shapes ribbon menu button group.

[image: clip0549] Adds a rectangular note.

[image: clip0550] Adds a Rounded rectangular note.

You will be prompted for the text.

[image: clip0551]


Enter the text and click the [image: clip0541] button

Move the mouse inside a graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to place the note or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and Enter/Space/Tab again to exactly set placement point.

[image: clip0261]


Now as you move the mouse the note will change in size and aspect ratio.

If you hold down the Shift key as you move the mouse, the note will be centered at the first point.

If you hold down the CTRL key as you move the mouse, the note will be square with the width and the height the same.

If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the note will be centered at the first point and will be square with the width and the height being the same.

Alternately, you can add a note image with a simple click, hold, and drag.  When the point cross is where you want to start the note, left-click and hold the left button. While holding the left button drag to re-size the note and release the button; the note will be placed.  In this mode, if you hit Enter before releasing the left button, you will be able to enter exact X and Y numerical values for the width and heights respectively. Note, using the Shift and CTRL keys as described above also works with this alternate method. 

[image: clip0553]


Dragging the mouse defines the rectangles size
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Adding Polylines





To add a polyline to a graphical sheet click on the [image: clip0270] button in the Add→Shapes ribbon menu button group.

To set the  Fill Styles and Line Styles before adding polylines use the Default Graphics Settings

[image: clip0261]


Polyline start point

Left-click when the start cross is where you want to start the polyline or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

Now as you move the mouse, the first segment of the polyline is defined. Left click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the first segment of the polyline.

[image: clip0273]


Defining the first segment

Now as you move the mouse, the second segment of the polyline is defined. Left-click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the second segment of the polyline.

[image: clip0272]


Defining the second segment

Moving the mouse again, the third segment of the polyline is defined. Left-click to define its end point or press theEnter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the third segment of the polyline.

[image: clip0271]


Defining the third segment

Continue this process to add as many line segments as you wish. 

Press the ESC key to remove the last vertex added.

Double-click to complete adding the polyline.

 

To close the polyline move the mouse over or very near the start of the polyline and left-click.

 







   Adding Polygons
   
   
   

   




Adding Polygons





To add a polygon to a graphical sheet click on one of the [image: clip0281]  buttons in the Add→Shapes ribbon menu button group.

To set the  Fill Styles and Line Styles before adding rectangles use the Default Graphics Settings

[image: clip0285] Draws a hollow polygon.

[image: clip0286] Draws a filled polygon with fill different from the outline.

[image: clip0287] Draws a filled polygon with no outline.

[image: clip0261]


Polygon start point

Left-click when the start cross is where you want to start the polygon or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

As you move the mouse, the first segment of the polygon is defined. Left-click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the first segment of the polygon.

[image: clip0284]


Defining the first segment

Now as you move the mouse the second segment of the polygon is defined. Left-click to define its end point or press the Enter key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the second segment of the polygon.

[image: clip0283]


Defining the second segment

Moving the mouse again, the third segment of the polygon is defined. Left-click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the first segment of the polygon.

[image: clip0282]


Defining the third segment

Continue this process to add as many line segments as you wish. 

Double-click to end the polygon or hit the ESC key to end the polygon with the last placed line segment.
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Adding Rectangles





You can add rectangles and rectangles with corners.

To set the  Fill Styles and Line Styles before adding rectangles use the Default Graphics Settings.

[image: clip0315]


Rectangles and rounded rectangles

To add a rectangle to a graphical sheet click on one of the [image: clip0307]  buttons in the Add→Shapes ribbon menu button group.

[image: clip0308] Adds a hollow rectangle.

[image: clip0309] Adds a filled rectangle with border.

[image: clip0310] Adds a filled rectangle without a border.

[image: clip0311] Adds a hollow rectangle with rounded corners.

[image: clip0312] Adds a filled rectangle with border with rounded corners.

[image: clip0313] Adds a filled rectangle without a border with rounded corners.

Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start a rectangle or press the Enter/Space/Tab key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

[image: clip0261]


Now as you move the mouse the rectangle will change in size and aspect ratio.

If you hold down the Shift key as you move the mouse, the rectangle will be centered at the first point.

If you hold down the CTRL key as you move the mouse, the rectangle will be square with width and height being the same.

If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the rectangle will be centered at the first point and will be square with the width and the height being the same.

Alternately, you can add a rectangle with a simple left click and hold then drag.  When the point cross is where you want to start a rectangle, left-click and hold the left button. Left-click and hold and drag to re-size the rectangle and release the button; the rectangle will be placed. In this mode, if you hit Enter before releasing the left button, you will be able to enter X and Y numerical values for the width and heights respectively. Note, using the Shift and CTRL keys as described above also works with this alternate method.

[image: clip0314]


Dragging the mouse defines the rectangles size
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Adding Text





You can add Text.

To set the  Fill Styles, Line Styles and Font Style  before adding text use the Default Graphics Settings.

[image: clip0547]


Text

To add text to a graphical sheet. click on the [image: clip0544]  button in the Add→Shapes ribbon menu button group.

You will be prompted for the text.

[image: clip0540]


Enter the text and click the [image: clip0541] button.

Move the mouse inside a graphical sheet's viewport. You will see the text cross follow the mouse. Left-click to place the text.

[image: clip0543]
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Artworks





Artwork files contain schematic symbols that do not have any electrical content, such as parts and wires. They are used for creating library artwork to be used in project and part files. They can also be used for any other drawing needs, as AutoTRAX DEX's powerful graphics allows you to graphical design engineering drawings.

Below is an example of artwork for a transformer with a center tap. It consists of a collection of arcs and lines. There are no symbol terminals. 

 

[image: clip0132]


You would use this when creating a custom transformer part.  To do this:

1.Create a new part.

2.Drag the artwork from the library.

3.Add the symbol terminals.

4.Save the part.

Below is a part created using the artwork and with terminals added

[image: clip0134]


You can also add artwork from the library onto another artwork file that you are editing. This allows you to build complex art using a bottom up design methodology.

You can also add artwork to the PCB. However if the artwork is drawn with a black pen, it will appear drawn black on black on the PCB, so you will need to change its color and layer to make it visible. Artwork will initially be placed on the top document layer. 
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Adding Artwork to the Library





To add artwork to the library:

1.Select the graphics for the artwork in the schematic. Any electrical items such as symbol terminals, although selected, will not be added to the artwork file.

2.In the Library Panel, right-click and select Add Selected Graphics. The dialog box shown below will be displayed.

3.Enter the name for the artwork and click the OK button. You can change the target directory by typing it in or clicking on the browse [image: clip0135] button.

Once added, you can drag the artwork from the library panel onto any schematic.

You can edit the saved artwork file in the library panel by double-clicking on its name or right-clicking on its name and select Edit Selected Part.

[image: clip0131]
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Automatic Generation of 3D model PCB Header





This video show the header produced by AutoTRAX DEX/Active3D.
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Add a Thermal Pad to a Footprint





This video shows you how to add a thermal pad to a footprint to help conduct heat away from the device.
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Capturing Pin Details from a PDF





This demonstration will show you how to quickly capture pin details for a schematic symbol from a PDF document. This will also work with text documents.
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Attributes





Distributor

Distributor's Website

Short Description

Full Description

Merge Lines into Paragraphs
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Adding Pads to Parametric Footprints





You can add additional non-parametric pads to a parametric part using the Add→Pads [image: clip0763] button group.

See Adding Pads.
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Adding Vias to Parametric Footprints





You can add vias to footprints by clicking on the add Via button in the add menu. 
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Adding Graphics to Parametric Footprints





You are free to add graphics to parametric footprints as well as non-parametric footprints.
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Adding Copper Areas to Parametric Footprints





To add a copper area to a footprint select the layer that you want the copper to be on and add a graphic shape such as a rectangle or circle.
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Adding 3D to Parametric Footprints





To add additional 3-D to a parametric footprint add any of the 3-D objects in the add menu.
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BGA Parts





To create a BGA part click the [image: clip0648] button in the The Part Builder

The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.[image: clip0652]

 

 

 

 

 

 

 

Device Overview
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Package Value
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Axial Parts





To create an Axial part click the  [image: clip0657]button in the The Part Builder

The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
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Pads 
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Package Value
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Chip Parts





To create a Chip part click the [image: clip0658] button in the The Part Builder

The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
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Pads 
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Package Reference 

Package Value
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Antenna Parts





You can create a coil pattern on a copper layer to act as a antenna coil.

To create an antenna part click the [image: clip0667] button in the The Part Builder

The part builder will automatically create the copper pattern and pads for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

[image: clip0723]


Schematic Symbol without outer ring

[image: clip0731]


[image: clip0722]


Copper pattern and pads

[image: clip0721]


3D View of the antenna
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Antenna





A PCB (Printed Circuit Board) antenna, also known as a trace antenna, is a type of antenna that consists of a trace drawn on a PCB. This can be a simple line or an intricate shape, depending on the specific antenna design and the frequency at which it is intended to operate.

Here are some popular types of PCB antennas:

Monopole Antenna

This is the simplest form of PCB antenna, consisting of a single straight line. These are easy to design and implement, but they require a ground plane to operate correctly.

Dipole Antenna

This antenna consists of two lines or traces of equal length, positioned end to end with a small space in between. This space is where the feed line connects. Dipole antennas do not require a ground plane to operate.

Inverted-F Antenna (IFA)

This type of antenna is a form of monopole antenna that has one end folded back over itself, forming a shape like an inverted "F". It is a popular choice for wireless communication devices because of its good performance and compact size.

Planar Inverted-F Antenna (PIFA)

A PIFA is essentially an IFA with the top section covered by a ground plane. It's a popular antenna for mobile phones due to its compact size and ability to operate at multiple frequencies.

Slot Antenna

This is an antenna made by cutting a slot into a metal surface or layer of the PCB.

Patch Antenna

This is a type of antenna that consists of a flat rectangular or square conductor mounted over a ground plane. They're often used for microwave frequency applications.

Fractal Antenna

This type of antenna uses a fractal pattern, which is a complex geometric shape that can be split into parts, each of which is a reduced-scale copy of the whole.

The design of a PCB antenna requires careful consideration of the desired frequency, bandwidth, efficiency, and directivity, among other factors. The materials, thickness of the board, and other components placed nearby can also have a significant effect on the antenna's performance.

 

It's always recommended to simulate the antenna design using appropriate software to predict its performance before fabricating the PCB. Testing the fabricated PCB antenna in a controlled environment can help validate its performance and make any necessary adjustments.
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Antenna Parameters





[image: clip0700]


Antenna Parameters

[image: clip0724]


Inner Radius. The inner radius. See the diagram above.

Track Width. The width of the copper track forming the antenna.

Trace Space. The space between copper rings. See the diagram above.

Rings. The number of complete rings.

Check the [image: clip0730] checkbox to use plated through holes for the pads. Uncheck to use SMT pads,

Check the [image: clip0725] checkbox is run the rings clockwise. Uncheck to run the rings in the opposite direction.

[image: clip0727]


Clockwise

[image: clip0726]


Anticlockwise

Check the [image: clip0729] checkbox to add an outer ring.

[image: clip0728]


Antenna with outer ring
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Axial





Axial PCB packages are a type of through-hole electronic component package that is commonly used for resistors, capacitors, and diodes. Axial components are named for the axial orientation of the leads (or legs) of the component, which are located at opposite ends of the component and extend outward along a common axis.

In an axial PCB package, the leads are typically inserted into plated through-holes on the PCB and then soldered to the PCB to form a mechanical and electrical connection. The leads can also be bent at a right angle to the component body and inserted into mounting holes on the PCB, where they are secured with a nut.

Axial PCB packages come in various shapes and sizes, and their dimensions depend on the specific component they are used for. Some common types of axial components include axial electrolytic capacitors, axial ceramic capacitors, and axial diodes.

One advantage of axial PCB packages is that they are relatively easy to install and remove, and can be inserted into the PCB by hand. They are also generally more robust than surface-mount components and are less prone to mechanical stress or damage.

However, axial PCB packages take up more space on the PCB than surface-mount components and can limit the density of other components around them. They are also less suitable for high-frequency applications due to their longer lead lengths, which can introduce unwanted inductance and capacitance into the circuit.

[image: An Axial Part With Banding]An Axial Part With Banding



[image: clip0883]

[image: clip0899]

To create an Axial part click the  [image: clip0657] button in the The Part Builder

The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
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Axial Parameters





[image: clip0694]
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BGA





Ball Grid Array (BGA) is a type of surface-mount packaging used for integrated circuits (ICs). BGA packages are used to permanently mount devices such as microprocessors. A BGA can provide more interconnection pins than dual in-line or flat packages.

Here are some characteristics of BGA ICs:

•Design: The bottom of the BGA is covered in solder balls (hence the name "Ball Grid Array"). These solder balls are placed at the locations where the IC needs to make electrical contact with the PCB. The solder balls are melted to attach the IC to the PCB, making both electrical and mechanical connections.

•High Density: Because the entire bottom of the BGA can be used for connections, it can accommodate a larger number of pins within the same space compared to packages that only have pins around the edge. This high density makes BGA a good choice for complex, high-performance ICs like microprocessors and FPGAs.

•Better Performance: The shorter and more direct paths between the IC and the PCB provided by the BGA design can result in better electrical and thermal performance compared to other packages.

•Soldering and Inspection: BGA packages can be harder to solder correctly compared to other packages, due to the fact that the solder balls are hidden underneath the IC. Specialized equipment is needed for both the soldering and inspection process.

•Rework and Repair: BGA packages are also challenging to rework or repair. If a solder joint fails or the IC needs to be replaced, specialized equipment and skills are required.

BGA ICs are commonly used in applications that require high performance and a large number of interconnections, such as in servers, networking equipment, high-end consumer electronics, and more.

To create a BGA part click the [image: clip0648] button in the The Part Builder

The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.[image: clip0652]
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A two-pin SMT (Surface Mount Technology) chip package is a type of package that is designed to be mounted on the surface of a printed circuit board (PCB), rather than being inserted through holes drilled in the board. This type of package is used for components such as resistors, capacitors, diodes, inductors, and certain types of integrated circuits.

Here are some characteristics of a 2-pin SMT chip package:

•Design: The package has two terminals or leads for electrical connection. These terminals are typically located on opposite ends of the package.

•Installation: The chip is placed on top of the PCB, and the leads are soldered directly to the board's surface. This is in contrast to through-hole components, which require holes to be drilled into the PCB for mounting.

•Package Types: Common types of 2-pin SMT chip packages include chip resistors and capacitors (typically in 0402, 0603, 0805, 1206 sizes, etc., where the numbers refer to dimensions in hundredths of inches), small signal diodes, LEDs, and various types of transistors.

•Applications: Two-pin SMT chip packages are used in virtually all modern electronic devices due to their small size, low cost, and ease of manufacturing.

•Advantages: Compared to through-hole components, SMT components are smaller and can be placed on both sides of the PCB, allowing for more compact and complex circuit designs. SMT components also typically provide better performance at high frequencies.

For these components to work correctly, they must be carefully designed into the PCB layout, properly placed and soldered onto the PCB, and thoroughly tested to ensure reliable performance.

[image: Chip Device]Chip Device



To create a Chip part click the [image: clip0658] button in the The Part Builder

The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
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[image: Chip Device]Chip Device
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[image:  SOT-223] SOT-223



SOT-223 is a type of package used for semiconductors, such as transistors and integrated circuits. The acronym "SOT" stands for Small Outline Transistor, and the number "223" refers to the specific form factor or physical dimensions of the package.

The package has three leads coming out from the bottom and an additional heat sink tab for better thermal dissipation. This is useful in applications where the device needs to dissipate a considerable amount of heat, such as power transistors.

SOT-223 packages are commonly used in surface-mount technology, which allows for high-density PCB (printed circuit board) assembly and automation-friendly manufacturing processes. Their design makes them compact and efficient, fitting well into modern electronic device design philosophies that prioritize space efficiency and power management.

For specific measurements or pin configuration of the SOT-223 package, you would need to refer to the datasheet of the particular component you are using, as these details can vary between manufacturers or even between different devices from the same manufacturer.
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Castellated PCB Parts





A castellated PCB (Printed Circuit Board) is a type of PCB that has its edges modified with plated holes or half-holes. These half-holes appear like the battlements, or "castellations," of a castle when viewed from the side, which is how the PCB gets its name.

Castellations are typically used to allow one PCB to be soldered to another. This is often used in the creation of modules, where a small PCB with a specific functionality is soldered onto a larger main PCB. These small castellated PCBs are usually called breakout boards or modules.

In terms of manufacturing, a castellated PCB is made by first creating a standard PCB with vias placed close to the edge, then milling the PCB edge, halving the vias. The half-vias are then plated to provide a good surface for soldering.

Common examples of this include Wi-Fi modules like the ESP8266 or ESP32, or sensor modules, that can be directly soldered onto another PCB, effectively making them a component of a larger system.

As with any PCB design, the specific layout, dimensions, and specifications of a castellated PCB will depend on its intended use and the requirements of the overall device it's a part of.
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Border





Symbols optionally have a terminal magnet. Terminal magnets server as anchor edges forces all symbol terminals to stick to the edge. Terminals cannot be dragged of the edge. As you drag a terminal the terminal will try to follow but it will always remain attached to the border.

Terminals always stick to a grid of 0.1 units. This gives you a good separation of terminals. Schematic wires snap to a 0.05 unit grid.

You can delete the border by selecting it and pressing the DEL key.

[image: clip1121]


A terminal magnet with no terminals

[image: clip1122]


A terminal magnet with terminals

[image: clip1123]


Organized by pin name

[image: clip1124]


Organized by name with grouping

[image: clip1125]


Pins on all 4 sides
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Pins on left


	[image: clip1127]


Pins on right
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Adding Terminals





To add a terminal click on one of buttons in the Add→Symbol button group.

[image: clip0412]
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Adding Graphics to Symbols





To add graphics to a symbol in a schematic:

Select the symbol and the graphics to add.

Click the Edit→Group→[image: clip0563] button.

The graphics will then be added to the internal data for the Symbol.
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Capturing Terminal Names From a Datasheet





Capturing Schematic Symbol Pin Details from a Datasheet
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Automatic 3D Pins
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[image: clip1554]

 

[image: clip1555]

 

[image: clip1556]

 

[image: clip1557]







   Adding 3D objects
   
   
   

   




Adding 3D objects





You can add 3D objects to a part. 

Use the [image: clip0399] button group in the Add menu.

1.Select either the top or bottom package layer as the current layer.

2.Add your graphics.

3.Set the height and base of the graphic using the properties panel.

 







   Adding Graphics to Footprint
   
   
   

   




Adding Graphics to Footprint





You can add graphics to any layer for a footprint. 

If the graphics are on the top, bottom or inner layers (copper layers), then they will be in copper and do have electrical significance.

 







   3D Packages
   
   
   

   




3D Packages





The Part Builder will automatically generate the 3D model for parametric parts.
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Bipolar Transistors (BJT)





The Bipolar Transistor model dialog is shown below.

[image: clip0366]


The Bipolar Transistor Model Dialog
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Capacitors





The capacitor model dialog is shown below.

[image: clip0367]


The Capacitor Model Dialog
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Adding Parts





You can add parts to a schematic by:

Using the Menu

Using the Library Panel

Adding Resistors
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Adding Resistors





To add a resistor click on of the [image: clip0442] buttons in the Parts→Resistors button group. The add resistor dialog shown below will appear. 

[image: clip0443]


Add Resistor Dialog
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Adding Ports





To add a port to a sub-system click the Add→Sub→[image: clip0569] button. 

[image: clip0570]


Enter the name for the port and click the [image: clip0571]button.

[image: clip0572]


Drag the port and left-click to finally place it.
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Adding a Sub-System





To add a sub-system to your design click the Add→Sub→[image: clip0496] button.

You will be prompted for the name of the sub-system.

[image: clip0497]


Enter its name and click the [image: clip0498] button.

Move the mouse in the schematic viewport. As you mouse the mouse the point cursor shown below will appear. Left-click when the point cross is where you want the start corner of the sub-system or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to precisely place the start corner of the sub-system.

[image: clip0499]


As you move the mouse you will see the sub-system re-size.

[image: clip0500]


Click the left mouse button when it is the correct size press the Enter key followed by the Width and Height coordinates of the sub-system shape.
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Adding Wires





To add a wire:

As you mouse the mouse the standard mouse cursor will be shown.

[image: clip0466]


No Connect

Move the wire over a terminal. The cursor will change to green. Click the left mouse button to start the wire.

[image: clip0467]


Start OK

Now drag the mouse. The wire will be drawn and a red arrow cursor will be shown.

[image: clip0468]


End Not OK

Move the wire over a terminal. The cursor will change to green. Click the left mouse button to end the wire.

[image: clip0469]


End OK
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Adding Buses





To add a bus click the Add→Bus→[image: clip0580] button.
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Beveling Wire to Bus Connections





To bevel/unbevel the wire to bus connectors click the Add→Bus→[image: clip0463] button.

 

[image: clip0464]


Unbeveled

[image: clip0465]


Beveled
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Adding Inter-Wire Connectors





To add a bus click the Add→Wire→[image: clip0582] button.
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Bus Editor





[image: clip2826]
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Adding V-Grooves





You can add V-Grooves to your panel. These are used to quickly snap apart the panel to separate out the individual PCBs.

[image: clip1379]


Add V-Grooves around the border of all the PCBs.

[image: clip1376]

V-Grooves on all 4 edges of the PCB array

[image: clip1380]


Add V-Grooves between the rows and columns of PCBs. 

[image: clip1377]

V-Grooves on all 4 edges of the PCB array and between PCBs

[image: clip1381]


Add twin cuts if you have non-zero column/row spacings.

[image: clip1378]

Twin cuts between PCB rows and columns

[image: clip1382]
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Adding Fiducials





To add 3 fiducial marks to your panel check the [image: clip1354] checkbox in the Panels control.

If checked, 3 fiducial marks in copper will be added to 3 corners of your panel as shown below.

Panel fiducials are called global fiducials by the IPC.

You can also added local 

Pick and Place Origin

If you add automatic fiducial to your panel then the origin for the Pick and Place file coordinates is set to the lower left fiducial else it is set to the bottom left corner of the panel.

[image: clip1353]
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Adding Tooling Holes





Tooling holes, while not as relevant as they used to be, are still valuable to have and do not usually cost any extra to add. You can put 4 of them in the corners and they are 3.175mm in diameter (which is 1/8" which was a standard pin support size that most of the industry standardized on in the 80's)

 

You can add 4 tooling holes 1/8" in diameter to the 4 corners of the panel

[image: clip1352]


Check Add Tooling Holes to automatically add 4 tooling holes.

[image: clip1364]
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Assembly Rails





When using pick and place machines to populate your PCBs you should add assembly rails to the edges of your panel.

The purpose of a frame around the panel is to make sure that if there are any parts that hang over the edges, they have clearance from machinery.

Rails should typically have a width of half an inch or 12.7mm. 

In order to save money, you may want just 2 rails instead of 4. In other words you will sometimes want rails on 2 sides instead of rails on all 4 sides.

If you are using only 2 rails then they should be on the long edge of the panel, not the short edge.

You can add optional assembly rails on:

1.Both the left and right side of the array of PCBs and/or

2.Both the top and bottom side of the PCB array.

Below are some examples of using assembly rails.

Single Design Before Panelization

[image: clip1359]


 

Panel for a PCB arrayed 56 times (8x7) With No Assembly Rails
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Top and Bottom Assembly Rails



	3.[image: clip1355]
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Left and Right Assembly Rails
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Assembly Rails on all 4 Sides
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Adding Holes to a PCB





To add a hole to a PCB click on the [image: clip0084] button in the Add→Cutouts button group. You will then be prompted for the diameter of the hole. Enter the hole diameter and click the [image: clip0086]button to add it. The value you enter is remembered by AutoTRAX DEX and used the next time you add a hole.

[image: clip0085]


As you move the cursor in the PCB viewport the hole will move. You will notice that the PCB will now be shown as a solid color, this is so you can see a true representation of the hole. The X and Y coordinate of the center of the hole will be displayed as shown below.

You can either:

•Move the mouse so the hole is positioned where you want it and left-click hold and drag, then release to create the hole 

•Left-click to start the hole then hit Enter, enter the X value, Enter, then the Y value, and finally enter to place the hole.

[image: clip0087]


NOTE: PCB holes are different to circular cutouts as they will be output as commands to the drill file. Circular cutouts are not output as drill commands.
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Adding Cutouts to a PCB





A cutout is a section of PCB that has been removed.

You can add 3 different types of PCB cutouts, rectangular, polygonal or circular/elliptical as shown below. Cutouts can extend to outside the basic PCB shape as shown in the elliptical cutout on the right of the PCB.

Adding a Rectangular PCB Cutout

Adding a Circular/Elliptical PCB Cutout

Adding a Polygonal PCB Cutout

[image: clip0088]


Cutouts in a PCB

[image: clip0089]


3D view of cutouts
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Adding a Rectangular PCB Cutout





To create a rectangular PCB cutout click the Add→Cutout→[image: clip0356] button.







   Adding a Circular/Elliptical PCB Cutout
   
   
   

   




Adding a Circular/Elliptical PCB Cutout





To create a rectangular PCB cutout click the Add→Cutout→[image: clip0357] button.







   Adding a Polygonal PCB Cutout
   
   
   

   




Adding a Polygonal PCB Cutout





To create a rectangular PCB cutout click the Add→Cutout→[image: clip0358] button.
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Adding Pads





To add a pad to a PCB or footprint click the one of the 4 [image: clip0446] buttons in the Add→Pads in the ribbon button group. [image: clip0445]

 Adding TPH pads

Click the [image: clip0447] button to add a round/elliptical TPH pad.

Click the [image: clip0448] button to add a rectangular TPH pad.

 Adding SMT pads

Click the [image: clip0449] button to add a round/elliptical SMT pad.

Click the [image: clip0447] button to add a round/elliptical SMT pad.

Placing the Pad

After you have clicked on one of the 4 buttons you will see the pad with a point input cursor. Move the pad to the position you wish and left-click or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the center of the pad.

[image: clip0452]


Pad with point input cursor

Settings

[image: clip0450] sets the size of square/circular pads 

[image: clip0451] sets the size of rectangular/elliptical pads 

Adding Pads in PCBs

If you add a pad in a PCB, a schematic symbol for the pad is automatically created and added to your first schematic. You can then use this to make connections.
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Adding Fiducials





Unlike practically all other EDA programs, AutoTRAX DEX is internally fiducials as first class objects and you do not need to and make them using a variety of different graphical objects. Your life is made a lot easier and fiducials are far easier to add to your designs.

It is possible to automatically add fiducials to a PCB.

It is also possible to automatically add fiducials to footprints using the parametric part builder.

In both cases it simply involves checking a tick box.
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Adding A Fiducial





You can manually add a fiducial to a Project PCB or to a Footprint land pattern.

To add a fiducial.

1.Click the Fiducial button  [image: clip1321] in the Add / PCB menu.

2.Move the mouse cursor in the PCB/land pattern viewport and click the left mouse button to finish.
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Automatically Adding Global Fiducials





You can automatically add global footprints to a PCB using the PCB board is property panel.

Select the PCB border by clicking on it.

In the PCB border properties panel click the add fiducials checkbox to automatically add three global fiducials.

The first one at the lower left of the PCB.

Another one above the first fiducial for.

Another one horizontally to the right of the first fiducial.

The origin of the PCB will be set to the center point of the first fiducial.
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Adding Global Fiducials





There are two different ways of adding global  fiducials to your PCB.

Global fiducials are used globally by all parts of the PCB and not by any specific part. Specific parts use what are called local fiducials. This naming convention is from the IPC specification.

 

1.The first way is to use the automatic features that are built into the PCB border properties panel. This is the easiest way to add fiducials.

2.The second way is to manually place the fiducial is by first clicking on the fiducial button in the add ribbon menu then moving the mouse cursor to the location that you want the fiducial to be and then clicking the mouse button.
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Adding Fiducials to a Footprint





You can quickly add fiducials to a footprint by either using the Part Builder or by actually manually placing the fiducials.

Fiducials added to a footprint of called local fiducials as opposed to the global fiducials that are added to a PCB. Generally you will use these local fiducials only for locating the individual footprint and it would not be used for located other footprints.

Using the Part Builder

[image: clip1334]


A court QFP device with no fiducials

[image: clip1336]


Check the 'Add Fiducial' checkbox to add local fiducials.

[image: clip1335]


A QFP device with 2 fiducials

Adding a Fiducial Inside a Part Editor

To add a local fiducial to a footprint inside the part editor click on the fiducial button [image: clip1338] in the add ribbon group and move the mouse cursor inside the viewport and click the left mouse button to position the fiducial.

 

Adding a Fiducial to a Placed Part

To add a local fiducial to a footprint inside the a project click on the fiducial button [image: clip1338] in the add ribbon group and move the mouse cursor inside the viewport and click the left mouse button to position the fiducial.

Next you need to place the fiducial inside the footprint. You can do this by first selecting the footprint and then, while holding down the shift key, selecting the fiducial that you placed and then by clicking and selecting the group menu item. This will move the fiducial inside the footprint.

 

Using the Parametric Part Builder you can add local fiducials to BGAs,QFPs, SOICs and DIPs

Check the [image: clip1343]button in the Properties Panel

[image: clip1339]


BGA

[image: clip1340]


QFP

[image: clip1341]


SOIC

[image: clip1342]


DIP
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Adding Nets





To add a net to a PCB:

1.Click on the Add→Add Net button in the menu.

2.Move the mouse so it is over a pad, via or track and the cursor will turn to a green tick. 

3.Left-click when you see the green tick to start a net.

4.Now move the mouse. As you move it a yellow line will be drawn from the source pad, via or track.

5.When the cursor goes over a valid end point for the net, the cursor will turn into a  green tick.

6.Left-click when you see the cursor turn to green tick. The net will then optimize itself.
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Changing a track segments layer index





To change the layer for a track segment, first select it by left-clicking it and then either press either the Space key or press a number key.

Obviously it is not possible to change the track segment's layer for single sided PCB.

Pressing the space key will send the current track segment backwards in the PCB layers. However if the track segment is on the bottom layer, then it will be cycled around to the top layer. For a 2-sided board pressing the space key appears to swap a track segment to the other side of the board.

When a layer segment is swapped, vias and/or track junctions will be added and/or removed as required.

Pressing a number key will move the selected track segment to the layer defined by the number entered or to the bottom layer if the number is greater than the number of electrical layers on the PCB.

e,g, pressing '1' moves the selected track segment to the top layer while pressing '2' moved it to the second layer, in the case of a 2-layered PCB, to the bottom of the PCB.

Pressing 't' or 'T' moves the track segment to the top layer

Pressing 'b' or ''B' moves the track segment to the top layer.

You can convert a track segment to a jumper on the top or the bottom side of the board. pressing the 'H' to create a jumper on the bottom side of the board or the 'J' key  to create a jumper on the top side of the board.
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Automatic Routing





AutoTRAX DEX has an internal auto-router. 
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Adding Keep Out Regions





To add a keep out region click on one of the [image: clip0574]buttons in the Add→Keepout ribbon button group/ 

Click [image: clip0576] to add a rectangular keep out region.

Click [image: clip0577] to add an elliptical keep out region.

Click [image: clip0578] to add a polygonal keep out region.

 

 

 







   Auto-Layout
   
   
   

   




Auto-Layout





To auto-layout your PCB click the Layout→PCB→[image: clip0458] button.







   An Insight into PCB Auto-Layout
   
   
   

   




An Insight into PCB Auto-layout
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Adding Copper Pour Regions





To add a copper pour areas click on one of the 3 buttons[image: clip0460] in the Add→Pour ribbon button group.

There are 3 basic shape type.

1.Rectangular

2.Elliptical/Circular

3.Polygonal.
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Adding Solder Mask Cutouts





In addition to the automatic cutouts for pads, you can add mask cutouts.

[image: clip1154]


Rectangular, elliptical and polygonal solder mask cutout

You can add solder mask cutout using the buttons in the Add->No Mask button group.

[image: clip1155]


Adding a rectangular solder mask cutout

To add a rectangular no solder mask area click on [image: clip1156].

1.Move the cursor to the top left or bottom right corner for the cutout.

2.Click the left mouse button and drag the mouse to define the cutout or just hold down the left mouse button and drag.

a. If you hold down the Shift key the cutout rectangle will be centered at the position you first clicked. 

b.If you hold down the Ctrl key the  cutout rectangle will be square.

c.You can hold down both the Shift and Ctrl key to create a square cutout centered at the original left click.

3.Click again to end adding the cutout or release the left mouse button if you started by holding down and dragging.

Adding an elliptical or circular solder mask cutout

To add an elliptical or circular no solder mask area click on [image: clip1158].

4.Move the cursor to the top left or bottom right corner for the cutout.

5.Click the left mouse button and drag the mouse to define the cutout or just hold down the left mouse button and drag.

a. If you hold down the Shift key the cutout ellipse/circle will be centered at the position you first clicked. 

b.If you hold down the Ctrl key the cutout will be a circle.

c.You can hold down both the Shift and Ctrl key to create a circle cutout centered at the original left click.

6.Click again to end adding the cutout or release the left mouse button if you started by holding down and dragging.

Adding a polygonal solder mask cutout

To add an elliptical or circular no solder mask area click on [image: clip1159].

1.Move the cursor to the first corner of the cutout and click the left mouse button.

2.Now drag the cursor to define the first edge and click to start the second edge.

3.Repeated drag and click to define additional edge.

4.Double click the complete the polygonal cutout.
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Changing a Solder Mask Cutout's Shape





Solder mask cutouts come in 3 different forms. Rectangular, elliptical and polygonal/curved.

To change the shape first select the cutout.

To switch between rectangular, elliptical and polygonal/curved cutouts, click on the top tab.

[image: clip1164]


 

 

 







   Adding Solder Paste to a Solder Mask Cutout
   
   
   

   




Adding Solder Paste to a Solder Mask Cutout





Normally a solder mask cutout will not have a solder paste applied.

To add solder paste, check [image: clip1166]

[image: clip1165]
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Adding Solder Mask Cutout to Footprints





You can add solder mask cutouts to footprints. When the part if placed on the PCB, the cutouts in the footprint will be added to the PCB. Swapping the side of a footprint will swap the side for all the cutouts.
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Adding Solder Paste





AutoTRAX DEX can automatically add solder paste for you.

You can optionally and your own custom solder paste areas.

SMT pads

Surface mounted pads automatically add a solder paste area. You can turn off the automatically added solder paste using the pad's properties panel.

TPH pads

Thru-plated hole (TPH) pads do not have solder paste automatically added.

No mask cutouts

No mask cutouts normally do not have solder paste but you can optionally have automatically generated solder paste added to the no mask cutouts.

Custom solder paste areas

Finally, you can add your own custom solder paste areas by adding any graphics to either the top solder mask layer or the bottom solder mask layer.

Layers panel

in the layers panel you will see to solder mask areas. The first one is above the top copper layer and the second one is below the bottom copper layer.

Normally this solder mask layers are off but you can easily turn them on using the layers panel.
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Adding Solder paste to SMT pads





By default SMT pads automatically add solder paste. However, you can disable this using the pads properties panel, see below.

 

[image: clip1213]


Enabling and disabling automatic solder paste generation

[image: clip1214]


Without solder paste

[image: clip1215]


With auto-generated solder paste

[image: clip1216]


Auto-generated solder paste disabled and 

custom shape added to solder paste layer

 







   Adding Solder paste to no mask areas
   
   
   

   




Adding Solder paste to no mask areas





To add solder paste to a no mask area first select either the top or bottom solder paste layer and add a graphic shape to that layer. The graphics shape will generate a solder paste area.

 

[image: clip1216]


Auto-generated solder paste disabled and 

custom shape added to solder paste layer
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Adding custom solder paste areas





To add solder paste to a no mask area first select either the top or bottom solder paste layer and add a graphic shape to that layer. The graphics shape will generate a solder paste area.

 

[image: clip1216]


Auto-generated solder paste disabled and 

custom shape added to solder paste layer
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Checking Your PCB Design





[image: clip1001]


To check your design use the Design Checker panel.

You can [image: clip1036] and [image: clip1037] the design rules.

The Design Rules Checker tests for:

•Unrouted Tracks

•Minimum Track Width

•Track Intersections

•Track to Track Clearance

•Track to Pad Clearance

•Track to Via Clearance

•Track to Hole Clearance

•Track to Cutout Clearance

•Track to Keepout Clearance

•Track to Border Clearance

 

•Minimum Pad hole Diameters

•Minimum Pad Annular Ring Size

•Pad to Pad Clearance

•Pad to Via Clearance

•Pad to Hole Clearance

•Pad to Cutout Clearance

•Pad to Border Clearance

 

•Minimum Via Hole Diameters

•Minimum Via Annular Ring Size

•Via to Via Clearance

•Via to Hole Clearance

•Via to Cutout Clearance

•Via to Keepout Clearance

•Via to Border Clearance

 

•Hole to Hole Clearance

•Hole to Cutout Clearance

•Hole to Border Clearance

 

•Cutout to Cutout Clearance

•Cutout to Border Clearance

 

•Courtyard to Courtyard Clearance

•Courtyard to Holes Clearance

•Courtyard to Cutouts Clearance

•Courtyard to Border Clearance

 

•Silkscreen to Pad Clearance

 

Each test can be optionally turned on or off. All tests are on by default.
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Adding 3D objects





There are 2 ways to add 3D objects to a PCB or footprint.

The first is using the Add→3D menu item.

•Adding Internal 3D Objects

The second is to import 3D from an external file.

•Adding Internal 3D Objects
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Adding Internal 3D Objects





Using the  Add→3D menu item

Use the [image: clip0399] button group in the Add→3D ribbon button group when editing the PCB.

1.Select either the top or bottom layer as the current layer.

2.Add your graphics.

3.Set the height and base of the graphic using the properties panel of the Edit 3D Object dialog that opens and click Done when finished.

See the example of adding a cylinder to the PCB below...

[image: Adding 3D Object-cylinder]


Adding a cylinder to a PCB using the 3D object tools from the Add→3D ribbon button Group
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Adding External 3D Objects





You can add  3D from an external file to both a PCB and a Footprint

Click on the Tools→Import→ [image: clip0954] button.

The import 3D file will be shown as shown below.

[image: clip0955]


Select a file and click [image: clip0956] to add it to the PCB.

The 3D model will be imported and embedded in a 3D Model.

Currently AutoTRAX DEX will only import XGL files.

The XGL file format is designed to represent 3D information for the purpose of visualization.  It attempts to capture all of the 3D information that can be rendered by SGI's OpenGL rendering library.  It uses XML 1.0 syntax.  These features make XGL the ideal format to use when data must be exchanged between two graphics systems for the purposes of visualization.

Autodesk Inventor will export to XGL.

You can find loads of free 3D models at https://www.3dcontentcentral.com/

To turn them into XGL files:

1.Download the 3D file from https://www.3dcontentcentral.com/ as a .SAT file.

2.Start Autodesk Inventor.

3.Open the downloaded .SAT file.

4.Export to a XGL file.

5.Import it into AutoTRAX DEX.
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3D Models





A 3D model is a 3D object imported from an external source.

[image: clip0957]


A Transformer 3D model

To set the vertical height of the object use its properties dialog in the The Properties Panel

[image: clip0958]


Drag the [image: clip0959] thumb-wheel to the left or right to raise or lower the object in above/below the PCB.
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3D View Control





 

You can set several viewing options for 3D using the 3D tab in the properties panel. Click on [image: clip1426] to expand the control.

[image: clip1390]

Viewing

This set of controls set the visibility of various parts of the PCB and also the thickness of the PCB.

[image: clip1385]

Board Thickness. This is the total thickness of the board including the copper layers on the upper and lower surfaces.

Copper Thickness. This is the thickness of the copper on the top and bottom side of the PCB.

Explode. Check this to create an exploded view of the PCB. This will show you the internals of the PCB.

Exploded View of the PCB

[image: clip1427]


Show Parts. Uncheck this to hide the parts and show only the PCB.

Show Parts Unchecked

[image: clip1428]


Show Holes. Check this to show the PCB holes. If unchecked the holes will not be visible.

Show Parts and Show Holes Unchecked

[image: clip1429]


Display Copper as Layer Color. Check this to display the copper with the same color as the color in the to the PCB view.

[image: clip1430]


Show Pads as Yellow. Check this to show all pads colored yellow.

[image: clip1432]


Draw All Copper Yellow. Check this to show all copper colored yellow.

All copper on the top and bottom of the PCB drawn as yellow.

[image: clip1431]


3D Tracks, Pads etc. Check to show the tracks, pads and other copper areas as 3-D. If unchecked then they will be added as texture to the surface of the PCB and will draw a lot faster but the quality will not be as good.

3D Copper

[image: clip1433]


2D Copper

[image: clip1434]


3D Add Solder. Checking this will add 3-D solder to all pad connections. 

3D Solder

[image: clip1435]


No 3D Solder

[image: clip1436]


 

Board Color

This sets the color of the board material. It does not set the color of the solder mask.

[image: clip1386]


Green Board

[image: clip1439]


Check [image: clip1419] to give the board a glass fiber type weave.

 

Drag the [image: clip1420] slider to enhance the appearance of the weave.



	No Weave

[image: clip1421]



	Enhanced Weave

[image: clip1422]









 

Solder Mask

This sets the visibility and color of the solder mask.

Check [image: clip1418]to show the solder mask.

[image: clip1387]


No Solder Mask

[image: clip1438]


Lighting

[image: clip1388]


Check [image: clip1423] to fix the position of the light relative to the PCB. If unchecked then the light is attached to the camera (Your viewing position) and move when you alter the viewpoint.

Hold down the left mouse button and drag it over the light track ball [image: clip1425] to set the position of the light.

 

Drag the [image: clip1424] slider to the right to increase the level of background/fill lighting.

 

Background Color

The 3D background is a vertical gradient from a top color to a bottom color.

At the top of the Background Color expansion group is a palette of preset gradient. Click on any of the 

[image: clip1389]


[image: clip1437]
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3D Exporting





The import/export ribbon group contains several useful commands for exporting 3-D.

[image: clip1393]

Click on the [image: clip1395] button to export a STL file.

Exporting a STL File

 

Click the [image: clip1396] will export the 3-D to a Wavefront OBJ file.

 

Export a Wavefront OBJ File

The [image: clip1397]  will export the 3-D to a Collada file.

Exporting a Collada 3D File

The [image: clip1398] button will create a POV RAY photo-realistic render file. If you have POV RAY installed then the POV RAY program will start and render your file in 3D. 

Exporting and Rendering with POVRAY
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Automatic Backups





AutoTRAX DEX automatically archives your work in a directory with the same name as your project but with the '.Backup' extension added. For example if you project is called 'My Project',  backups are saved to  'My Project. Backup'  as shown below.

The backups have the save name with the date appended and a short description of the action that caused a backup to be made.

It is a good idea to use some 3rd party automatic backup software to backup this directory, giving you full confidence that none of your work will be lost.

AutoTRAX DEX will never delete any of these files even if you undo changes you make.

[image: clip0108]


List of Automatically archived copies of the current project.
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Adding New Sub-Systems





To add a sub-system to a schematic click the Add→Sheets→[image: clip0122] button.

You will then see the following dialog box. 

[image: clip0123]


Enter the name of the new sub-system. In this case Amplifier and click the OK button.

Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start a rectangle or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the starting point.

[image: clip0746]


Now drag the mouse and you will see the border change in size. Left-click when the point cross is where you want to end the Sub-System or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the end point.

[image: clip0747]


 The Sub-System reference is shown below.

[image: clip0124]


Double-clicking inside the blue rectangle for the sub-system reference will open the sub-system's schematic sheet.
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Adding Terminals to a Sub-system Reference





There are 2 different ways to add terminals to a sub-system reference.

•Add terminals directly to the sub-system reference.

•Open the sub-system reference's schematic by doubling-clicking on or in the sub-system reference's border and adding ports.

Adding terminals directly to the sub-system reference

To add terminals directly to the sub-system reference:

1. Select the sub-system reference by clicking on or in it's border. (If there is only 1 sub-system reference or part in the schematic then you do not need to do this as AutoTRAX DEX knows what to add the terminal to.)

2. Click on one of the symbol terminals in the Symbols group in the Add ribbon menu.

[image: clip0125]


The symbol terminal dialog box will appear.

[image: clip0127]


3. Enter the Name and click the Add button.

4. Now move the mouse around the sub-system reference. You will see the terminal move around and try to follow the mouse. Left-click to finally place the terminal.

Repeat 1-4 to add more terminals.

When you add terminals to a sub-system reference, ports are automatically added to the sub-system reference's schematic.

For more about symbol terminals click here.
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Adding Sub-Systems References





To add a sub-system reference the Add→Sub→[image: clip0562] ribbon button group.

[image: clip0558]


Select the sub-system and click the [image: clip0559] button to add it.

Click the [image: clip0560] button to create a new sub-system and add a reference to it. Enter its name.

[image: clip0561]
 







   Your Bill of Materials
   
   
   

   




Your Bill of Materials





To generate a Bill of Materials (BOM) file click the Tools→CAM→[image: clip0341] button.

A bill of materials or product structure (sometimes bill of material, BOM or associated list) is a list of the raw materials, sub-assemblies, intermediate assemblies, sub-components, parts and the quantities of each needed to manufacture an end product. A BOM may be used for communication between manufacturing partners, or confined to a single manufacturing plant. A bill of materials is often tied to a production order whose issuance may generate reservations for components in the bill of materials that are in stock and requisitions for components that are not in stock.

A BOM can define products as they are designed (engineering bill of materials), as they are ordered (sales bill of materials), as they are built (manufacturing bill of materials), or as they are maintained (service bill of materials or pseudo bill of material). The different types of BOMs depend on the business need and use for which they are intended. In process industries, the BOM is also known as the formula, recipe, or ingredients list. The phrase "bill of material" (or BOM) is frequently used by engineers as an adjective to refer not to the literal bill, but to the current production configuration of a product, to distinguish it from modified or improved versions under study or in test.

In electronics, the BOM represents the list of components used on the printed wiring board or printed circuit board. Once the design of the circuit is completed, the BOM list is passed on to the PCB layout engineer as well as component engineer who will procure the components required for the design.

Items in a Bill of Materials

 

[image: clip1460]
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Adding Text  Document Sheets





To add a text documents to your design click the Home→Sheet→[image: clip0361] button.
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Circuit Simulation





AutoTRAX DEX uses the SPICE 3f5 circuit simulator.

SPICE is an analog-circuit simulator that is used to calculate and display the circuit behavior. It was originally developed at the Electronics Research Laboratory of the University of California, Berkeley (1975). The source code was made freely available and has been used as the basis of many commercial simulators, and academic projects.

SPICE is a useful tool, not a magic wand, and its results should always be examined critically; in some cases it may not give results at all, for others the results may be misleading.

 

Sample Projects

Simulation Samples

 

Adding Circuit Elements

Adding Circuit Elements

Adding Voltage and Current Sources

Always Add a Ground

 

Instruments

Adding Instruments

 

Analysis Result

The Analysis Probe

 

The Spice Reference Manual
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Bridge Rectifier







	 


	[image: Download the Project]








The bridge rectifier uses four diodes connected as shown below. When the input cycle is positive as in part (a), diodes D1 and D2 are forward-biased and conduct current in the direction shown. A voltage is developed across R1 that looks like the positive half ofthe input cycle. During this time, diodes D3 and D4 are reverse-biased.

When the input cycle is negative as in Figure 2–38(b), diodes D3 and D4 are forwardbiased and conduct current in the same direction through RL as during the positive half-cycle. During the negative half-cycle, D1 and D2 are reverse-biased. A full-wave rectified output voltage appears across RL as a result of this action.

Bridge Output Voltage 

A bridge rectifier with a transformer-coupled input is shown in Figure 2–39(a). During the positive half-cycle of the total secondary voltage, diodes D1 and D2 are forward-biased. Neglecting the diode drops, the secondary voltage appears across the load resistor. The same is true when D3 and D4 are forward-biased during the negative half-cycle.

 

[image: clip1601]


The Spice Probe shows the electrical signals.

[image: clip1602]
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Adding Circuit Elements





There are many different circuit elements you can add to your schematic.

Passive Devices

Adding a Resistor

Adding a Capacitor

Adding an Inductor

Adding a Transformer

Active Devices

Adding a BJT Transistor

Adding a JFET Transistor

Adding a MOSFET Transistor

Adding a MESFET Transistor
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Adding a Resistor





Coming soon...
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Adding a Capacitor





Coming soon...
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Adding an Inductor





Coming soon...
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Adding a Transformer





Coming soon...
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Adding a Diode





Coming soon...
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Adding Transistors





You can add 4 types of transistor to your design.

•BJT Transistor

•JFET Transistor

•MOSFET Transistor

•MESFET Transistor
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Adding a BJT Transistor





Coming soon...
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Adding a JFET Transistor





Coming soon...







   Adding a MOSFET Transistor
   
   
   

   




Adding a MOSFET Transistor





Coming soon...







   Adding a MESFET Transistor
   
   
   

   




Adding a MESFET Transistor





Coming soon...
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Adding Voltage and Current Sources





Independent Sources

To add an independent source click on one of the buttons in the Simulate→Source ribbon button group 

[image: clip0352]
.

Dependent Sources

To add an dependent source click on one of the buttons in the Simulate→Source ribbon button group

[image: clip0353]
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Adding Independent Sources





Coming soon...
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Adding Instruments





You can add virtual electrical instruments to your schematics.

Adding a Power Supply

Adding a Signal Generator

Adding an Oscilloscope

Adding a Chart







   Adding a Power Supply
   
   
   

   




Adding a Power Supply





Coming soon...
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Adding a Signal Generator





Coming soon...
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Adding an Oscilloscope





Coming soon...
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Adding a Chart





Coming soon...
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Always Add a Ground





For the simulator to work you must include a ground connection.

[image: clip0349]


No ground, simulation not possible

[image: clip0350]


Ground present, simulation now possible
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Analysis at Different Temperatures





All input data for SPICE is assumed to have been measured at a nominal temperature of 27 C, which can be changed by use of the TNOM parameter on the .OPTION control line. This value can further be overridden for any device which models temperature effects by specifying the TNOM parameter on the model itself. The circuit simulation is performed at a temperature of 27 C, unless overridden by a TEMP parameter on the .OPTION control line. Individual instances may further override the circuit temperature through the specification of a TEMP parameter on the instance. 

Temperature dependent support is provided for resistors, diodes, JFETs, BJTs, and level 1, 2, and 3 MOSFETs. BSIM (levels 4 and 5) MOSFETs have an alternate temperature dependency scheme which adjusts all of the model parameters before input to SPICE. For details of the BSIM temperature adjustment, see [6] and [7]. 

Temperature appears explicitly in the exponential terms of the BJT and diode model equations. In addition, saturation currents have a built-in temperature dependence. The temperature dependence of the saturation current in the BJT models is determined by: 

where k is Boltzmann's constant, q is the electronic charge, e.g. is the energy gap which is a model parameter, and XTI is the saturation current temperature exponent (also a model parameter, and usually equal to 3). 

The temperature dependence of forward and reverse beta is according to the formula: 

where T1 and T0 are in degrees Kelvin, and XTB is a user-supplied model parameter. Temperature effects on beta are carried out by appropriate adjustment to the values of F, ISE, R, and ISC (spice model parameters BF, ISE, BR, and ISC, respectively). 

Temperature dependence of the saturation current in the junction diode model is determined by: 

where N is the emission coefficient, which is a model parameter, and the other symbols have the same meaning as above. Note that for Schottky barrier diodes, the value of the saturation current temperature exponent, XTI, is usually 2. 

Temperature appears explicitly in the value of junction potential, (in spice PHI), for all the device models. The temperature dependence is determined by: 

where k is Boltzmann's constant, q is the electronic charge, Na is the acceptor impurity density, Nd is the donor impurity density, Ni is the intrinsic carrier concentration, and Eg is the energy gap. 

Temperature appears explicitly in the value of surface mobility, 0 (or UO), for the MOSFET model. The temperature dependence is determined by: 

The effects of temperature on resistors is modeled by the formula: 

where T is the circuit temperature, T0 is the nominal temperature, and TC1 and TC2 are the first- and second-order temperature coefficients. 
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Circuit Description





The circuit to be analyzed is described to SPICE by a set of element lines, which define the circuit topology and element values, and a set of control lines, which define the model parameters and the run controls. 
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Circuit Elements and Models





The circuit element include:

•Transistors and Diodes 

•Transmission Lines

•Voltage and Current Sources
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Bipolar Junction Transistors (BJTs)





General form: 

QXXXXXXX NC NB NE <NS> MNAME <AREA> <OFF> <IC=VBE, VCE> 

<TEMP=T> 

Examples: 

Q23 10 24 13 QMOD IC=0.6, 5.0 Q50A 11 26 4 20 MOD1 

NC, NB, and NE are the collector, base, and emitter nodes, respectively. NS is the (optional) substrate node. If unspecified, ground is used. MNAME is the model name, AREA is the area factor, and OFF indicates an (optional) initial condition on the device for the dc analysis. If the area factor is omitted, a value of 1.0 is assumed. The (optional) initial condition specification using IC=VBE, VCE is intended for use with the UIC option on the .TRAN control line, when a transient analysis is desired starting from other than the quiescent operating point. See the .IC control line description for a better way to set transient initial conditions. The (optional) TEMP value is the temperature at which this device is to operate, and overrides the temperature specification on the .OPTION control line. 
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BJT Models (NPN/PNP)





The bipolar junction transistor model in SPICE is an adaptation of the integral charge control model of Gummel and Poon. This modified Gummel-Poon model extends the original model to include several effects at high bias levels. The model automatically simplifies to the simpler Ebers-Moll model when certain parameters are not specified. The parameter names used in the modified Gummel-Poon model have been chosen to be more easily understood by the program user, and to reflect better both physical and circuit design thinking.

The dc model is defined by the parameters IS, BF, NF, ISE, IKF, and NE which determine the forward current gain characteristics, IS, BR, NR, ISC, IKR, and NC which determine the reverse current gain characteristics, and VAF and VAR which determine the output conductance for forward and reverse regions. Three ohmic resistances RB, RC, and RE are included, where RB can be high current dependent. Base charge storage is modeled by forward and reverse transit times, TF and TR, the forward transit time TF being bias dependent if desired, and nonlinear depletion layer capacitances which are determined by CJE, VJE, and MJE for the B-E junction , CJC, VJC, and MJC for the B-C junction and CJS, VJS, and MJS for the C-S (Collector-Substrate) junction. The temperature dependence of the saturation current, IS, is determined by the energy-gap, EG, and the saturation current temperature exponent, XTI. Additionally base current temperature dependence is modeled by the beta temperature exponent XTB in the new model. The values specified are assumed to have been measured at the temperature TNOM, which can be specified on the .OPTIONS control line or overridden by a specification on the .MODEL line.

The BJT parameters used in the modified Gummel-Poon model are listed below. The parameter names used in earlier versions of SPICE2 are still accepted.



	name


	parameter


	units


	default


	example


	area





	IS


	transport saturation current


	A


	1.0e-16


	1.0e-15


	*





	BF


	ideal maximum forward beta


	-


	100


	100


	 





	NF


	forward current emission coefficient


	-


	1.0


	1


	 





	VAF


	forward Early voltage


	V


	infinite


	1


	 





	IKF


	corner for forward beta high current roll-off


	A


	infinite


	200


	*





	ISE


	B-E leakage saturation current


	A


	0


	0.01


	*





	NE


	B-E leakage emission coefficient


	-


	1.5


	1.0e-13


	 





	BR


	ideal maximum reverse beta


	-


	1


	2


	 





	NR


	reverse current emission coefficient


	-


	1


	0.11


	 





	VAR


	reverse Early voltage


	V


	infinite


	1200


	 





	IKR


	corner for reverse beta high current roll-off


	A


	infinite


	2000.01


	*





	ISC


	leakage saturation current


	A


	0


	0.01.0e-13


	*





	NC


	leakage emission coefficient


	-


	2


	1.5


	 





	RB


	zero bias base resistance


	Ohm


	0


	100


	*





	IRB


	current where base resistance falls halfway to its min value


	A


	infinite


	0.1


	*





	RBM


	minimum base resistance at high currents


	Ohm


	RB


	10


	*





	RE


	emitter resistance


	Ohm


	0


	1


	*





	RC


	collector resistance


	Ohm


	0


	10


	*





	CJE


	B-E zero-bias depletion capacitance


	F


	0


	2pF


	*





	VJE


	B-E built-in potential


	V


	0.75


	0.6


	 





	MJE


	B-E junction exponential factor


	-


	0.33


	0.33


	 





	TF


	ideal forward transit time


	sec


	0


	0.1ns


	 





	XTF


	coefficient for bias dependence of TF


	-


	0


	 


	 





	VTF


	voltage describing VBC dependence of TF


	V


	infinite


	 


	 





	ITF


	high-current parameter for effect on TF


	A


	0


	 


	*





	PTF


	excess phase at freq=1.0/(TF*2PI) Hz


	deg


	0


	 


	 





	CJC


	B-C zero-bias depletion capacitance


	F


	0


	2pF


	*





	VJC


	B-C built-in potential


	V


	0.75


	0.5


	 





	MJC


	B-C junction exponential factor


	-


	0.33


	0.5


	 





	XCJC


	fraction of B-C depletion capacitance connected to internal base node


	-


	1


	 


	 





	TR


	ideal reverse transit time


	sec


	0


	10ns


	 





	CJS


	zero-bias collector-substrate capacitance


	F


	0


	2pF


	*





	VJS


	ubstrate junction built-in potential


	V


	0.75


	 


	 





	MJS


	substrate junction exponential factor


	-


	0


	0.5


	 





	XTB


	forward and reverse beta temperature exponent


	-


	0


	 


	 





	EG


	energy gap for temperature


	eV


	1.11


	 


	 





	XTI


	temperature exponent for effect on IS


	-


	3


	 


	 





	KF


	flicker-noise coefficient


	-


	0


	 


	 





	AF


	flicker-noise exponent


	-


	1


	 


	 





	FC


	coefficient for forward-bias depletion capacitance formula


	-


	-.5


	 


	 





	TNOM


	Parameter measurement temperature


	ºC


	27


	50
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Capacitors





General form:

CXXXXXXX N+ N- VALUE <IC=INCOND>

Examples:

CBYP 13 0 1UF COSC 17 23 10U IC=3V 

N+ and N- are the positive and negative element nodes, respectively. VALUE is the capacitance in Farads.

The (optional) initial condition is the initial (time-zero) value of capacitor voltage (in Volts). Note that the initial conditions (if any) apply 'only' if the UIC option is specified on the .TRAN control line.
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Analysis and output Control





The following analyzes are available:

•DC or Small-Signal AC Sensitivity Analysis

•DC Transfer Function

•Distortion Analysis

•Fourier Analysis

•Initial Conditions

•Noise Analysis

•Operating Point Analysis

•Pole-Zero Analysis

•Small-Signal AC Analysis

•Transfer Function Analysis

•Transient Analysis
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Analysis Options





The Analysis Options dialog box is shown below.

Select the option to change by clicking the left mouse button over the option name.

For full details on the options see Simulator variables.

Reset to default. Click to set the options back to the SPICE defaults.

Use default value. Check to use the default value. Uncheck to change the value.

OK. Click to accept your changes.

Cancel. Cancel your changes.

Help. Display this help topic.
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The User Interface





The AutoTRAX DEX workspace has had years to develop into a fine tuned working environment, and with bigger monitors and faster processors, working with AutoTRAX DEX has only become more fun. With all the room that larger display options give you, you can easily organize the panels, viewports and tools in the workspace to provide an efficient designing environment.

What is DPI and why does it matter?

DPI stands for dots per inch, where a dot represents a physical device pixel. (The nomenclature comes from printing, where dots are the smallest ink dot that a printing process can produce). HDPI stands for high dots per inch.

Historically, monitors shipped with 96 pixels per inch. The Windows operating system drew a bitmap that represented 96 DPI as 100%. But as display technology progressed, that DPI threshold was surpassed. Monitors started shipping with display panels close to 300 DPI or higher.

While higher pixel density produces sharper images, some sort of display scaling is required to size elements on the screen properly. Otherwise, user interface (UI) elements and text are too tiny to use effectively and can overlap. To help remedy this, Windows automatically scales the UI percentile to match the DPI setting. For example, a DPI setting of 100% represents 96 DPI, where 125% is 120 DPI, and 150% is 144 DPI. This automatic scaling affects text, graphics, controls, and window sizes.

Here's where DPI-aware vs. DPI-unaware comes in. When an application declares itself to be DPI-aware, it's a statement specifying that the app behaves well at higher DPI settings and so Windows can apply auto-scaling. Conversely, DPI-unaware applications render at a fixed DPI value of 96 pixels per inch, or 100%, and so auto-scaling isn't applied.

AutoTRAX is now fully DPI-aware

AutoTRAX DEX provides a consistent, single, highly configurable program interface to enable you to create parts, PCBs and even engineering artwork.

With all its features, AutoTRAX DEX can be a bit daunting at first. The purpose of this chapter is to familiarize you with the AutoTRAX DEX workspace and how to navigate around AutoTRAX DEX, find tools, customize settings, and set the working environment so it best suits you.

So, without further ado let's look at the AutoTRAX DEX workspace as shown below. 

[image: workspace]


Typical Layout

[image: Ribbon]


Parts of aTypical Layout
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Auto-Repeat commands





In AutoTRAX DEX, there are times when it is convenient to repeat the last command immediately.  For example, you may want to place the same part on a graphical sheet more than once.  The Auto-Repeat commands feature in AutoTRAX DEX is quite handy for this.  When enabled, the last command completed will automatically be repeated.  When this feature is enable to quit repeating the last command hit the ESC key.

To enable/disable the Auto-Repeat commands feature, in any viewport, right-click and select Auto-Repeat commands from the context menu displayed.  See below...

 

[image: right-click context menu]
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Arranging Viewports





Viewports can be arranged in a tabbed layout or a tiled or cascaded layout.

Floating Viewport

Viewports can also be floated onto other screens or the current screen.

AutoTRAX DEX remembers the position of the viewports when the program ends and restores them when the program starts.

Floating viewports are only enabled when you have a tabbed layout.

To float a viewport double-click on the tab at the top of the viewport or hold down the left mouse button and drag the tab.
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Auto Filter Row





The automatic filtering row allows data to be filtered on the fly by typing text into that row. When you type text into this filtering row, a filter condition is automatically created based on the entered value and then applied to the focused column. The automatic filtering row is displayed at the top of the Grid View.

 

[image: clip2478]


 

When the top data row is focused, you can move focus to the auto filter row by pressing the CTRL + UP ARROW keys.
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Advanced Filter and Search Concepts





Filter Expressions

A filter expression is a formula (or a set of formulas) that specifies how data should be filtered. Each expression contains three parts:

•a data field whose values should be filtered;

•a filtering value that should be compared to records stored in the data field;

•an operator that compares data field values with a filtering value.

For example, the following expression selects all the "Count" data field values that are greater than 5 but less than 20:

[Count] Between ('5', '20')

Filter Expression Syntax

The table below enumerates most frequently used operators. 



	Operator


	Description


	Example





	=


	Equals. Selects data field values that equal the entered filtering value.


	[OrderDate] = #2016-01-01#





	<>


	Does not equal. Selects data field values that are not equal to the entered filtering value.


	[OrderDate] <> #2016-01-01#





	>


	Is greater than. Selects data field values that are greater than the entered filtering value.


	[OrderDate] > #2016-01-01#





	>=


	Is greater than or equal to. Selects data field values that are greater than the entered filtering value or equal to it.


	[OrderDate] >= #2016-01-01#





	<=


	Is less than or equal to. Selects data field values that are less than the entered filtering value or equal to it.


	[OrderDate] >= #2016-01-01#





	<


	Is less than. Selects data field values that are less than the entered filtering value.


	[OrderDate] >= #2016-01-01#





	Between


	Is between. Selects data field values that belong to the specific value interval.


	[CustomerID] Between ('1', '100')





	Not Between


	Is not between. Selects data field values that lie outside the specific value interval.


	Not [CustomerID] Between ('1', '100')





	Contains


	Contains. Selects data field values that contain the filtering value.


	Contains([ShipCountry], 'land')





	Not Contains


	Does not contain. Selects data field values that do not contain the filtering value.


	Not Contains([ShipCountry], 'land')





	Starts with


	Begins with. Selects data field values that start with the filtering value.


	StartsWith([ShipCountry], 'G')





	Ends with


	Ends with. Selects data field values that ends with the filtering value.


	Ends with([ShipCountry], 'ia')





	In


	Is any of. Selects data field values that equal any of the entered filtering values.


	[ShipCountry] In ('Germany', 'Italy', 'USA')





	Not In


	Is none of. Selects data field values that do not equal any of the entered filtering values.


	Not [ShipCountry] In ('Germany', 'Italy', 'USA')





	Like


	Is like. Selects data field values that contain the filtering value.

Accepts wildcards: '_' to replace a single character, '%' to replace any number of characters.


	[OrderDate] Like '%2011'

same as

Contains ([OrderDate], '2011')





	Not Like


	Is not like. Selects data field values that do not contain the filtering value.

Accepts wildcards: '_' to replace a single character, '%' to replace any number of characters.


	Not [OrderID] Like '103__'

same as

Not [OrderID] Between ('10300', '10399')





	Is Null


	Is null. Selects null values.


	[ShipRegion] Is Null





	Is Not Null


	Is not null. Excludes null values.


	[ShipRegion] Is Not Null








 

•String values must be enclosed within single quote characters. If a single quote character needs to be included as a literal to a filter, it must be doubled (e.g., [ProductID] LIKE 'Uncle Bob''s%');

•Date-time values must be wrapped with the '#' characters and represented using a culture-independent (invariant) format. The invariant culture is based on the English culture, but some of the idiosyncratic English formats have been replaced by more globally-accepted formats. Below are some of the culture-independent formats for representing date-time values.

MM/dd/yyyy — 07/30/2008

dd MMM yyyy — 30 JUL 2008

yyyy-MM-dd — 2008-07-30

yyyy-MM-ddTHH:mm:ss — 2008-07-30T22:59:59

yyyy-MM-dd HH:mm:ssZ — 2008-07-30 15:59:59Z
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The AutoTRAX DEX Website





The AutoTRAX DEX website is at https://pcbdex.com

[image: clip0642]


On the web site you fill find many useful features including:

•Download Details

•Download Archives

•Tutorial Videos

•Screen Shots and Slide Shows

•Support Topics

•Free Gerber Viewers

•Running AutoTRAX DEX on Apple Macs.

•Purchase Details

•Renewal Details and how to get updates for another 12 months.

•Contacting Us

•Company Details
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The Software License

The IPC
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Built-in variables





 

Coming soon...







   An Informal Introduction to Python
   
   
   

   




An Informal Introduction to Python





In the following examples, input and output are distinguished by the presence or absence of prompts (>>> and ...): to repeat the example, you must type everything after the prompt, when the prompt appears; lines that do not begin with a prompt are output from the interpreter. Note that a secondary prompt on a line by itself in an example means you must type a blank line; this is used to end a multi-line command.

Many of the examples in this manual, even those entered at the interactive prompt, include comments. Comments in Python start with the hash character, #, and extend to the end of the physical line. A comment may appear at the start of a line or following whitespace or code, but not within a string literal. A hash character within a string literal is just a hash character. Since comments are to clarify code and are not interpreted by Python, they may be omitted when typing in examples.

Some examples:

# this is the first comment

spam = 1  # and this is the second comment

          # ... and now a third!

text = "# This is not a comment because it's inside quotes."

 

Using Python as a Calculator

Let’s try some simple Python commands. Start the interpreter and wait for the primary prompt, >>>. (It shouldn’t take long.)

Numbers

The interpreter acts as a simple calculator: you can type an expression at it and it will write the value. Expression syntax is straightforward: the operators +, -, * and / work just like in most other languages (for example, Pascal or C); parentheses (()) can be used for grouping. For example:

>>>

>>> 2 + 2

4

>>> 50 - 5*6

20

>>> (50 - 5.0*6) / 4

5.0

>>> 8 / 5.0

1.6

 

The integer numbers (e.g. 2, 4, 20) have type int, the ones with a fractional part (e.g. 5.0, 1.6) have type float. We will see more about numeric types later in the tutorial.

The return type of a division (/) operation depends on its operands. If both operands are of type int, floor division is performed and an int is returned. If either operand is a float, classic division is performed and a float is returned. The // operator is also provided for doing floor division no matter what the operands are. The remainder can be calculated with the % operator:

>>>

>>> 17 / 3  # int / int -> int

5

>>> 17 / 3.0  # int / float -> float

5.666666666666667

>>> 17 // 3.0  # explicit floor division discards the fractional part

5.0

>>> 17 % 3  # the % operator returns the remainder of the division

2

>>> 5 * 3 + 2  # result * divisor + remainder

17

 

With Python, it is possible to use the ** operator to calculate powers [1]:
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 Text Fonts and Colors





In schematic diagrams, text fonts and colors are essential elements used to convey information and improve the readability and visual appeal of the circuit design. Properly chosen fonts and colors can make the schematic more understandable, organized, and easier to interpret. They help distinguish different elements and highlight critical information in the design.

Here are some considerations for schematic graphics text fonts and colors:

Text Fonts: Selecting an appropriate font is crucial for readability. Fonts should be clear, legible, and easy to read, even when the schematic is printed in smaller sizes. Commonly used fonts in schematics include Arial, Helvetica, Times New Roman, Verdana, and Calibri.

Text Sizes: Text sizes should be consistent and suitable for the specific application. Title texts and labels for important components may have larger font sizes, while annotations and less critical information may have smaller font sizes.

Bold and Italic: Using bold or italic text can help emphasize important information, titles, or section headings in the schematic.

Colors

Choosing appropriate colors can help organize the schematic and distinguish different types of elements. For instance:

oBlack: Typically used for most text and component outlines.

oRed: Often used for power-related information, such as power supplies and voltage references.

oBlue: Commonly used for net names or signal labels.

oGreen: Frequently used for ground connections and ground symbols.

oBrown: Used for component reference designators.

oGray: Sometimes used for annotations or non-critical information.

•Contrast: Ensure sufficient contrast between the text and background colors to avoid readability issues.

•Consistency: Maintaining consistent font styles and colors throughout the schematic improves its visual coherence and readability.

•Text Alignment: Align text neatly to improve the appearance and organization of the schematic.

•Annotations: Use text annotations to provide additional information, notes, or explanations about specific parts of the design.

•Text Orientation: In some cases, text orientation may be adjusted to fit in tight spaces or for better visual alignment.

It's essential to use fonts and colors judiciously to avoid overwhelming the schematic with too many variations, which may lead to confusion. Strive for a balanced and visually appealing layout that clearly conveys the necessary information.

The AutoTRAX DEX PCB Designer  offer a range of font styles, sizes, and color options, allowing designers to customize the appearance of text elements in their schematics. Additionally, software tools often include design rule checks (DRC) to ensure proper font sizing and readability in the final output.
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Bipolar Junction Transistors





In SPICE (Simulation Program with Integrated Circuit Emphasis), a BJT (Bipolar Junction Transistor) model is used to simulate the behavior of bipolar transistors, which are semiconductor devices commonly used in electronic circuits for amplification and switching. BJT models in SPICE describe the electrical characteristics of the transistor, including its current-voltage relationships, capacitances, and other parameters that affect its operation.

There are various BJT models available in SPICE, each with its level of complexity and accuracy. Some of the most commonly used BJT models in SPICE include:

Ebers-Moll Model

This is a basic and widely used model that represents the BJT as a current-controlled current source. It captures the fundamental characteristics of a bipolar transistor, including the relationships between base current, collector current, and emitter current.

The Ebers-Moll model is a simplified but fundamental model used to describe the behavior of bipolar junction transistors (BJTs) in electronics. It provides a basic representation of how current flows through the various regions of a BJT: the emitter, base, and collector. The Ebers-Moll model is widely used in SPICE simulations and other electronic design tools to analyze and predict the behavior of bipolar transistors.

The model is named after its developers, John S. Ebers and John L. Moll, who introduced it in the early 1950s. It focuses on the relationships between currents and voltages in a BJT and is based on the following key assumptions:

The BJT operates in the active region, where both the emitter-base junction and the collector-base junction are forward-biased.

The BJT operates in a small-signal AC regime, where variations in current and voltage are small around a quiescent (DC) operating point.

The Ebers-Moll model provides insights into the relationships between the voltages and currents in a BJT. It's a good starting point for understanding BJT behavior and can be useful for basic analysis, such as gain calculations and determining bias points. However, the Ebers-Moll model has limitations and does not capture all the complexities of real-world BJT behavior, such as high-frequency effects, parasitic capacitances, and other non-ideal characteristics.

For more accurate and detailed simulations, higher-level BJT models like the Gummel-Poon model or advanced models are used. These models take into account additional parameters and effects for more precise analysis of transistor behavior.

Gummel-Poon Model 

The Gummel-Poon model is an extension of the Ebers-Moll model and is a more comprehensive and accurate representation of bipolar junction transistors (BJTs) in electronic circuit simulations. Named after its developers, Hermann Gummel and John Poon, this model includes additional parameters and effects to better describe the behavior of BJTs in various operating conditions.

The Gummel-Poon model enhances the Ebers-Moll model by accounting for several factors that affect BJT operation, such as:

•High-Frequency Effects: The Gummel-Poon model introduces capacitances and transit time effects, which are important in high-frequency operation. These effects are not captured by the basic Ebers-Moll model.

•Early Voltage : The Early voltage is included in the Gummel-Poon model to account for the Early effect, where an increase in collector current leads to a reduction in the effective base width. This effect affects the output characteristics of the transistor.

•Base Resistance: The Gummel-Poon model includes a base resistance term to account for the resistive nature of the base region. This resistance affects the input characteristics and voltage-divider action in the BJT.

•Temperature Effects: The Gummel-Poon model includes parameters that account for the temperature dependence of various transistor parameters, which is essential for accurate simulations over a range of temperatures.

•Emitter Saturation Current : The Gummel-Poon model introduces the emitter saturation current, which is more accurate than the Is parameter in the Ebers-Moll model.

•Additional Model Parameters: The Gummel-Poon model includes additional parameters to capture various non-ideal effects, making it suitable for a wider range of BJT applications.

The Gummel-Poon model provides a more realistic representation of BJT behavior and is particularly useful for analyzing BJT performance in various biasing and operational conditions, including high-frequency operation. However, it is also more complex and requires more parameter values to be accurately defined compared to the Ebers-Moll model.

Modified Gummel-Poon Model (MGP)

The Modified Gummel-Poon (MGP) model is an advanced extension of the Gummel-Poon model for simulating bipolar junction transistors (BJTs) in electronic circuit designs. Like the Gummel-Poon model, the MGP model includes additional parameters and effects to better capture the behavior of BJTs under various operating conditions. The MGP model further refines and enhances the accuracy of the simulation results compared to the Gummel-Poon model.

The key improvements introduced by the Modified Gummel-Poon model include:

•Improved Temperature Dependencies: The MGP model includes more accurate temperature dependencies for various parameters, making it suitable for simulations over a wide range of temperatures.

•More Detailed Transit Time Modeling: The transit time effects in the MGP model are modeled with increased accuracy, accounting for the transit time variations with collector current and voltage.

•Advanced Base Resistance Modeling: The MGP model introduces a more sophisticated representation of the base resistance and its impact on transistor performance.

•Enhanced Early Voltage Model: The Early voltage  model in the MGP model is designed to provide better accuracy over a wider range of operating conditions.

•Bias-Dependent Current Sources: The MGP model includes bias-dependent current sources that consider the impact of operating conditions on transistor behavior.

•Higher Accuracy at High Frequencies: The MGP model provides improved accuracy in high-frequency simulations compared to the standard Gummel-Poon model.

The Modified Gummel-Poon model addresses some of the limitations and inaccuracies associated with the Gummel-Poon model, especially in scenarios involving temperature variations, high-frequency operation, and complex biasing conditions. It is a suitable choice for accurate simulations of BJTs in various electronic circuits, including analog amplifiers, RF circuits, and mixed-signal designs.

It's important to note that as the complexity of the model increases, so does the number of parameters that need to be accurately characterized for specific transistors. Therefore, careful attention to model parameter extraction and verification is crucial for obtaining reliable simulation results.

Designers often select the appropriate level of BJT model based on the complexity of their design, the accuracy required, and the level of detail necessary to capture the transistor's behavior under different conditions

Level-1, Level-2, Level-3, etc. Models

These models are increasingly complex and accurate, incorporating more parameters to represent various aspects of transistor behavior in greater detail. Higher-level models consider effects like parasitic capacitances, transit time effects, and temperature dependencies.

When using a BJT model in SPICE simulation, you typically need to provide parameters that define the transistor's characteristics, such as doping concentrations, junction area, and transit times. The accuracy of the simulation depends on the choice of the model and the accuracy of the provided parameters.

To simulate a circuit containing BJTs in SPICE, you generally need to:

Include the appropriate BJT model in your SPICE netlist.

Specify the model parameters based on the specific transistor you are using.

Connect the transistor in the circuit with proper biasing and connections.

Set up your simulation (DC analysis, AC analysis, transient analysis, etc.).

Run the simulation to observe the behavior of the BJT and the entire circuit.

Keep in mind that BJT models are part of a larger SPICE simulation setup, and the accuracy of the simulation depends on the quality of the model, the chosen simulation settings, and the accuracy of the provided transistor parameters. It's important to refer to the documentation of your specific SPICE software for information on BJT models and their usage.







   Annular Rings
   
   
   

   




Annular Rings





The annular ring on a printed circuit board (PCB) is the area of copper pad that extends around the circumference of a drilled and finished (usually plated) hole. This ring is vital for providing a reliable connection between the hole (via or through-hole) and the conducting layers of the PCB.

Here are some key considerations and rules regarding annular ring design:

Size

The size of the annular ring is critical. If it's too small, there might be a poor connection or no connection at all. If it's too large, it may unnecessarily consume PCB real estate. The minimum annular ring size is generally defined by the manufacturer's capabilities and is often in the range of 1-6 mils (0.001-0.006 inches) for outer layers and 1-1.5 mils for inner layers.

Tolerance

Fabrication tolerances, including drilling accuracy and alignment, also play a role in defining the annular ring size. There can be a positional variance during drilling, so a larger annular ring allows for these potential misalignments.

Plating

Most vias are plated with copper to electrically connect different layers of the PCB. The plating process can reduce the size of the annular ring, so this must be taken into consideration when defining the initial size.

Mechanical Stress

Annular rings are more vulnerable to mechanical stress than other parts of the PCB. High levels of mechanical stress can cause the annular ring to fracture or separate from the PCB substrate, leading to circuit failure. Therefore, if your board is expected to experience high levels of mechanical stress (like in a high vibration environment), you might want to use larger annular rings.

Thermal Stress

Thermal cycles can cause expansion and contraction of the PCB material and the copper annular ring. This mismatch can cause cracks in the annular ring or separation from the substrate, leading to circuit failure. If your design is intended for a high-temperature environment or will experience thermal cycles, you may need to use larger annular rings.

Cost and Design Complexity

As with other aspects of PCB design, larger annular rings increase reliability but can also increase cost and decrease the density of the design. So, a balance must be struck between reliability, cost, and design complexity.

In conclusion, the size of the annular ring in your PCB design will depend on a number of factors, including manufacturing capabilities and tolerances, the expected mechanical and thermal environment, and cost and design considerations. Always consult with your manufacturer to understand their specific requirements and capabilities.
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 Design Rules for Component Placement





When designing a PCB (Printed Circuit Board), several rules need to be considered during the component placement stage. These rules help to optimize the PCB layout for manufacturability, reliability, and performance. Here are a few key rules:

Decoupling Capacitors Placement

These should be placed as close as possible to the power pins of the respective ICs (Integrated Circuits) to minimize loop area and maximize their effectiveness.

Orientation

Components should be placed in the same orientation to prevent mistakes during the assembly process. This is particularly important when dealing with polarized components such as diodes, capacitors, and ICs.

Thermal Management

Power components that dissipate a lot of heat should be placed in such a way that they can be cooled efficiently. If a heat sink or forced air cooling is used, enough clearance must be provided.

Avoid Mechanical Stress

Avoid placing components near the board edges, holes, or cut-outs to reduce the risk of mechanical stress which could lead to failure. Also, consider the placement of heavy components - they may require additional board support to prevent damage.

Leave Enough Space

 It's important to leave enough space between components to accommodate the size of the soldering tool and to allow for heat dissipation. Also, allow for enough space to route traces between components.

Analog and Digital Ground Separation: If a PCB contains both analog and digital components, keep them separated on the board and consider splitting the ground plane to avoid noise interference.

High-Frequency Components

For high-speed or high-frequency designs, consider the length and routing of the signal paths. Shorter paths are preferable, and the path of critical signals should be as direct as possible.

Design for Testability

Components should be placed in a way that test points are accessible for testing and debugging. This is especially important for automated testing setups.

Design for Manufacturing

Component placement should consider the capabilities and limitations of the manufacturer’s assembly equipment. Some may have restrictions on component density, size, or orientation.

 

Remember that these are general rules, and the specific requirements for component placement can vary greatly depending on the complexity of the design, the application of the board, and other factors. Always consult with your PCB manufacturer to ensure your design can be produced reliably and cost-effectively.
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 PCB Layer Configurations





PCB layer configuration refers to the arrangement and stack-up of the copper layers in a printed circuit board. The layer configuration is determined by the complexity of the circuit, the density of components, and the specific design requirements. Here are some common PCB layer configurations:

Single-Layer PCB

A single-layer PCB consists of only one layer of copper on one side of the substrate. This is the simplest and most cost-effective type of PCB, typically used for low-density and simple circuits.

[image: A Single-Layer PCB Stack]A Single-Layer PCB Stack



Double-Layer PCB

A double-layer PCB has copper traces on both sides of the substrate. The two copper layers are connected through vias (plated through-holes). This configuration allows for more complex circuitry and increased component density compared to single-layer PCBs.

[image: A Double-Layer PCB Stack]A Double-Layer PCB Stack



Multi-Layer PCB

Multi-layer PCBs have three or more copper layers separated by insulating material (usually a pre-preg). The number of layers can range from 4 to over 30, depending on the complexity of the circuit. The additional layers provide more routing space, better signal integrity, and improved power and ground plane distribution.

Common multi-layer configurations

Four-Layer PCB

A four-layer PCB typically consists of two internal signal layers and two external plane layers (usually power and ground planes). It is commonly used in medium-density designs.

[image: A Four-Layer PCB Stack]A Four-Layer PCB Stack



Six-Layer PCB

A six-layer PCB adds two additional signal layers to the four-layer configuration. It offers more routing space and is suitable for higher-density designs.

[image: A Six-Layer PCB Stack]A Six-Layer PCB Stack



Eight-Layer or More

[image: An Eight-Layer PCB Stack]An Eight-Layer PCB Stack



PCBs with eight or more layers provide even greater flexibility and space for routing, power distribution, and signal integrity optimization. These configurations are used for complex and high-density designs, such as advanced electronics or high-speed applications.

The choice of PCB layer configuration depends on the complexity of the circuit, the desired electrical performance, and the available space in the system or enclosure. It's important to consider factors such as signal integrity, power distribution, and thermal management when determining the appropriate layer configuration for your PCB design.
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 Plating of PCB Holes and the Copper Balance





The process of plating holes in a printed circuit board (PCB) is crucial for creating plated-through holes (PTH), which are used to electrically and mechanically connect different layers of the PCB. Plating adds a layer of copper to the walls of the drilled holes, allowing electrical current to pass through.

The plating process typically involves several steps:

Desmear and Etch

As discussed earlier, the drilled holes are first cleaned (desmeared) and etched to provide a clean, rough surface for good plating adhesion.

Copper Seed Layer Deposition 

A thin layer of copper is chemically deposited onto the hole walls. This serves as a "seed" layer for the subsequent electroplating process.

Electroplating

The PCB is immersed in an electroplating bath, which contains a solution of copper ions. An electric current is passed through the bath, causing the copper ions to deposit onto the seed layer and form a thicker layer of copper.

Electroless Nickel/Immersion Gold (ENIG) or Other Surface Finish

To protect the copper from oxidation and improve solderability, a surface finish such as ENIG, HASL (Hot Air Solder Leveling), or OSP (Organic Solderability Preservatives) might be applied.

It's crucial to maintain a balance of copper across the PCB during the plating process. Copper imbalance can lead to issues like warping or bowing of the PCB due to different rates of thermal expansion and contraction. Copper imbalance can also lead to uneven plating, where some areas of the PCB (including some holes) might have more or less plating than others.

To achieve copper balance, PCB designers aim to evenly distribute copper across the PCB's surface and throughout its layers. This may involve adding copper pours or thieving patterns in areas without active circuitry. It's also important for the PCB manufacturer to carefully control their plating process to ensure even and consistent plating thickness.

Failure to maintain copper balance can lead to issues with the PCB's mechanical stability and electrical performance, so it's a crucial consideration in PCB design and manufacturing.
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Automated Pick and Place





Automated Pick and Place is a critical process in the assembly of printed circuit boards (PCBs). The Pick and Place machine is designed to accurately place electronic components on the PCB, quickly and precisely, enabling high-speed assembly of complex electronics.

[image: A Pick and Place Machine]A Pick and Place Machine
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PCB testing refers to the process of evaluating and verifying the functionality, quality, and reliability of printed circuit boards (PCBs). Testing is a critical stage in the PCB manufacturing and assembly process to ensure that the boards meet the required specifications and standards. PCB testing helps identify and rectify potential issues, defects, or errors before the PCBs are deployed in electronic devices or systems. There are several types of PCB testing, including:

Visual Inspection: Visual inspection is the initial step, where PCBs are visually examined for any obvious defects, such as missing components, soldering issues, or physical damage.

Automated Optical Inspection (AOI): AOI is a more advanced inspection method that uses cameras and software to automatically inspect PCBs for defects in solder joints, component placement, and other issues with high accuracy and speed.

In-Circuit Testing (ICT): ICT is a functional test that checks the electrical connections and verifies the performance of individual components on the PCB. This test is usually performed by a specialized test fixture that interfaces with the PCB's test points.

Boundary Scan Testing (JTAG): Boundary scan testing is a method for testing digital circuits on PCBs using the Joint Test Action Group (JTAG) interface. It allows for the testing of interconnected components and detecting faults in non-accessible areas.

Functional Testing: Functional testing involves testing the entire PCB or its sections by simulating real operating conditions and measuring the response to different inputs. This test verifies the overall functionality of the PCB in its intended application.

In-Circuit Emulation (ICE): ICE is used for testing complex digital circuits and microcontrollers. It involves using a special emulator to execute instructions and check the behavior of the circuit.

Thermal Testing: Thermal testing subjects the PCB to temperature extremes to evaluate its performance under varying thermal conditions and to identify potential thermal issues.

Environmental Testing: Environmental testing involves exposing the PCB to extreme conditions like humidity, vibration, and temperature to assess its robustness in harsh environments.

Reliability Testing: Reliability testing is conducted to determine the PCB's long-term performance and endurance under stress conditions to ensure its reliability over time.

Electrical Testing: General electrical testing includes checking for shorts, open circuits, continuity, impedance, and other electrical parameters using specialized test equipment.

X-ray Inspection: X-ray inspection is used to examine the internal structure of PCBs, especially for complex multilayer PCBs, to identify issues like misalignment, voids in solder joints, and delamination.

Each of these testing methods has its advantages and is used at different stages of the PCB manufacturing and assembly process to ensure that the final PCBs meet the required quality standards and specifications.
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The IPC (Institute for Printed Circuits) is a global trade association that develops standards, training programs, and certification programs for the electronics industry. 

IPC is the global association that helps OEMs, EMS, PCB manufacturers, cable and wire harness manufacturers and electronics industry suppliers build electronics better. IPC members strengthen their bottom line and build more reliable, high-quality products through proven standards, certification, education and training, thought leadership, advocacy, innovative solutions and industry intelligence.

IPC standards are widely used in the design, manufacturing, and assembly of printed circuit boards (PCBs). IPC standards are updated regularly to reflect changes in technology and industry best practices. They are used by PCB designers, manufacturers, assemblers, and test engineers to ensure that PCBs are designed and manufactured to the highest standards of quality and reliability.

Here are some examples of IPC standards related to PCB design:

IPC-2221: Generic Standard on Printed Board Design

This standard provides guidelines and design rules for the design of printed circuit boards. It covers topics such as board size, layer stackup, trace width, spacing, and other factors that affect the electrical performance and manufacturability of the board.

IPC-7351: Generic Requirements for Surface Mount Design and Land Pattern Standard

This standard provides guidelines for the design of surface mount land patterns for components. It covers topics such as pad size, shape, and placement, and it provides guidance on how to ensure proper solder joint formation.

IPC-6012: Qualification and Performance Specification for Rigid Printed Boards

This standard defines the requirements for the manufacture of rigid printed circuit boards. It covers topics such as material specifications, electrical performance, and testing requirements.

IPC-2223: Sectional Design Standard for Flexible Printed Boards

This standard provides guidelines for the design of flexible printed circuit boards. It covers topics such as materials, layer stackup, trace routing, and termination.

IPC-4101: Specification for Base Materials for Rigid and Multilayer Printed Boards

This standard defines the requirements for the materials used in the manufacture of printed circuit boards. It covers topics such as material properties, testing methods, and performance requirements.
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Active electronic parts are components that require a power source to operate and can control or amplify electrical signals. These parts typically use semiconductor materials, such as silicon, to manipulate the flow of electricity.

Examples of active electronic parts include:

Transistors

These are semiconductor devices that can amplify or switch electronic signals. They are used in a wide range of electronic circuits, including amplifiers, oscillators, and power controllers.

Transistors are semiconductor devices used to amplify or switch electronic signals and electrical power. They are one of the basic building blocks of modern electronic devices and are found in almost all electronic devices. In a Printed Circuit Board (PCB), transistors play critical roles in various circuit functions such as signal amplification, regulation, switching, signal modulation, and many others.

Transistors have three layers of semiconductor material and two pn junctions, hence they are sometimes referred to as a "double junction" device. The three parts of a transistor are the emitter, the base, and the collector.

There are two main types of transistors:

Bipolar Junction Transistors (BJTs): BJTs use both electron and hole charge carriers and are known for their amplification properties. They come in two types, NPN and PNP, which are distinguished by the direction of the current flow when in operation.

Field Effect Transistors (FETs): FETs control the electrical behavior of a device using an electric field. FETs come in many forms including Junction Gate Field-Effect Transistors (JFETs) and Metal Oxide Semiconductor Field-Effect Transistors (MOSFETs). They are widely used in applications like signal amplification and switching.

Transistors, like other electronic components, can be either through-hole or surface mount (SMD) and come in a variety of packages. The type of transistor and its specifications are typically printed on the body of the component, though some smaller SMD transistors might not have this due to their size.

When designing a PCB, it's important to consider the specifications of the transistor, including its maximum current, voltage ratings, gain, frequency response, and power dissipation. These parameters will depend on the application the transistor is being used for.

Diodes

These are components that allow current to flow in one direction while blocking it in the other. They are used in electronic circuits as rectifiers, voltage regulators, and signal demodulators.

Diodes are semiconductor devices used in electronic circuits that allow current to flow in one direction only. They have two terminals, an anode and a cathode. Current can flow from the anode to the cathode, but not in the other direction.

Diodes come in many forms and are used for a wide range of applications in a Printed Circuit Board (PCB). Here are some common types of diodes:

Rectifier Diodes: These are the most basic type of diode and are often used for converting alternating current (AC) to direct current (DC), a process known as rectification.

Schottky Diodes: These diodes have a lower forward voltage drop than regular diodes, which means they waste less energy. They are often used in power supply circuits.

Zener Diodes: These diodes can be designed to allow current to flow in the reverse direction when a specific set voltage (the Zener voltage) is reached. They're often used for voltage regulation.

Light Emitting Diodes (LEDs): These diodes emit light when current passes through them and are used for indication and lighting purposes.

Photodiodes: These diodes generate a current when they are exposed to light. They're used in various light sensing applications.

Diodes can come in both through-hole and surface-mount (SMD) varieties. The orientation of a diode when it's installed on a PCB is crucial, as installing it backwards will prevent the circuit from functioning properly. On schematics and on the diode itself, the cathode is usually marked with a line.

In terms of identifying diodes, the specific type and specifications of a diode are typically indicated by a printed code on the component's body. However, because of their small size, SMD diodes might not always have this code printed on them. Instead, you may need to refer to the manufacturer's datasheet or the PCB's bill of materials to identify them.

Integrated circuits (ICs)

These are miniaturized electronic circuits that can perform multiple functions. They are used in a wide range of electronic devices, including computers, smartphones, and medical equipment.

Integrated Circuits (ICs) are complex assemblies of transistors, diodes, resistors, and capacitors built onto a single piece of silicon, often referred to as a chip. These chips are encapsulated in a package that is then mounted onto a Printed Circuit Board (PCB). ICs are used to perform a wide range of functions in electronic devices.

ICs come in many different types and are used for a wide range of applications on a PCB, including:

Microprocessors and Microcontrollers: These are complex ICs that can perform computations and execute instructions. They are used as the brains of many types of electronic devices, from computers and smartphones to smaller devices like digital watches and microwave ovens.

Memory Chips: These ICs store data. Types of memory chips include RAM (Random Access Memory), ROM (Read Only Memory), and flash memory.

Analog ICs: These ICs process analog signals and can function as amplifiers, filters, and oscillators. Examples include operational amplifiers (op-amps) and voltage regulators.

Digital ICs: These ICs handle digital signals and include logic gates, flip-flops, counters, and shift registers.

Mixed Signal ICs: These ICs contain both analog and digital circuits. They are used in devices like smartphones, where they might handle both the digital processing of data and the analog processing of audio signals.

ICs can be either through-hole or surface mount. The specifications for an IC are usually found in its datasheet, which can often be found online. The datasheet will provide important details about the IC's function, pin configuration, recommended operating conditions, and other specifications.

ICs can come in a variety of packages, including Dual In-line Package (DIP), Small Outline IC (SOIC), Quad Flat Package (QFP), and Ball Grid Array (BGA), among others.

Selecting the correct IC for your application and ensuring that it is correctly implemented in your circuit design is a key aspect of PCB design. It's also important to ensure that the IC is correctly soldered to the PCB and that any necessary heat sinking or cooling is provided, as ICs can generate significant amounts of heat during operation.

Microcontrollers

These are specialized ICs that can control the operation of electronic systems. They are used in a wide range of applications, including automotive, industrial, and consumer electronics.

Microcontrollers are a type of integrated circuit (IC) that contain a processor core, memory, and programmable input/output peripherals. Essentially, they are a computer on a single chip designed to control electronic devices.

Microcontrollers are used in automatically controlled products and devices, such as automobile engine control systems, remote controls, office machines, appliances, power tools, toys, and other embedded systems. They are the "brains" behind many smart devices and are ubiquitous in the modern world.

Most microcontrollers are designed to execute complex digital instructions for specific tasks. A single microcontroller can contain a processor, memory (both RAM and ROM), and input/output (I/O) interfaces for connecting with other components or devices.

Different microcontrollers offer different sets of peripherals like digital I/O pins, analog-to-digital converters (ADCs), digital-to-analog converters (DACs), UARTs (serial ports), I2C or SPI interfaces, pulse-width modulation (PWM) capabilities, and even built-in Wi-Fi or Bluetooth in some cases.

Microcontrollers are programmable, which means that they can be loaded with code that determines how they operate. This code can be written in a variety of programming languages, including assembly language, C, C++, and in some cases, higher-level languages like Python or JavaScript. The code is typically written on a separate computer, then loaded onto the microcontroller using a programmer or a serial interface.

Microcontrollers come in various packages, from traditional through-hole Dual In-line Package (DIP) to various Surface Mount Technology (SMT) packages like Quad Flat Package (QFP), Ball Grid Array (BGA), and many others.

Popular families of microcontrollers include the PIC series from Microchip, the AVR series from Atmel (including the ATmega series used in Arduino boards), the MSP430 series from Texas Instruments, and the ARM Cortex series from ARM Holdings, among others.

When designing with microcontrollers, it's crucial to consider factors such as processing power, memory size, power consumption, availability of needed peripherals, cost, and the availability of software tools and libraries to support development.

Operational amplifiers (op-amps)

These are high-gain voltage amplifiers that can be used to amplify and manipulate electronic signals. They are used in a wide range of electronic circuits, including filters, oscillators, and power controllers.

Operational amplifiers, often abbreviated as op-amps, are a type of integrated circuit (IC) that can amplify voltage. They are one of the most common types of ICs used in analog electronics and can be used in a wide variety of electronic devices.

Op-amps have two input pins and one output pin. The two input pins are labeled as the inverting input (usually denoted with a minus sign) and the non-inverting input (usually denoted with a plus sign). The output voltage of the op-amp is a multiplication of the difference between the voltages applied to the two input pins and the gain of the op-amp.

Op-amps are versatile devices and can be used in a wide variety of circuits, including amplifiers, filters, comparators, and oscillators, among others. The specific function of an op-amp in a circuit depends on how the circuit is designed.

There are many different types of op-amps, each with its own specifications and characteristics. Some are designed for general use, while others are designed for specific applications, such as audio amplification, precision measurements, or high-speed signal processing. The specifications of an op-amp, including its gain, bandwidth, noise performance, and power consumption, will vary depending on its design.

Op-amps can be either through-hole or surface-mount, and they come in a variety of packages, including Dual In-Line Package (DIP), Small Outline Integrated Circuit (SOIC), and many others.

When designing a circuit that uses an op-amp, it's important to select an op-amp that meets the requirements of the circuit in terms of its specifications. It's also important to design the circuit correctly to ensure that the op-amp operates in its linear region (where it can accurately amplify signals), unless it's being used in a non-linear application such as a comparator or an oscillator.


Overall, active electronic parts play a crucial role in modern electronic devices and equipment, and their correct selection and integration are critical to the performance and reliability of electronic systems.
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Aligning objects in Schematic/PCB design is a crucial aspect of creating a well-organized and visually appealing layout. Proper alignment ensures that components, traces, pads, and other elements are precisely positioned relative to each other, making the design easier to understand, manufacture, and troubleshoot. Most Electronic Design Automation (EDA) software tools offer various alignment options to help designers achieve accurate and consistent object alignment. Here are some common methods for aligning objects in PCB design:

Manual Alignment: Most PCB design tools allow you to manually select multiple objects and move them to align with each other. This method gives you fine control over object placement and alignment.

Snap to Grid: Enabling the "Snap to Grid" feature ensures that objects are automatically aligned with the grid lines. This feature is especially helpful when aligning objects along straight horizontal or vertical lines.

Distribute: The "Distribute" function in PCB design software allows you to evenly distribute selected objects horizontally or vertically. This is useful for creating uniform spacing between components or traces.

Centering: You can center objects with respect to the horizontal or vertical axis of the design canvas. Centering is especially useful for aligning components or groups of components within specific areas of the design.

Reference Points: Some tools allow you to set reference points on objects and align other objects to those reference points. This is helpful when aligning objects based on specific points rather than the object's boundaries.

Grouping: Grouping objects allows you to treat them as a single entity, making it easier to align and move multiple objects together while maintaining their relative positions.

Alignment Tools: Many PCB design tools provide dedicated alignment tools that offer various alignment options, such as aligning objects left, right, top, bottom, center, or distributing them evenly.

Using Guides: Creating guides on the canvas helps guide the alignment of objects. You can snap objects to guides to achieve precise alignment.

Keyboard Shortcuts: The AutoTRAX DEX PCB Designer offers keyboard shortcuts for alignment, making it quicker to align objects without needing to navigate through menus.

When aligning objects, it's important to consider the specific requirements of your design, such as component clearances, trace routing, and signal integrity. Careful alignment helps improve the overall quality and manufacturability of the PCB design.
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